My Forms: cannot view created form

  • Profile Image
    Fleur
    Asked on August 08, 2019 at 04:03 AM

    Hello there,

    I created a form using Jotform yesterday. However, today the edit link (attached) doesn't work anymore so I cannot access the data, which is very inconvenient since I already sent the form to about 500 people...! Is there anything I can do to resolve this?

    Thanks.

    Warm wishes,
    Fleur

  • Profile Image
    ashwin_d
    Answered on August 08, 2019 at 04:51 AM

    I am sorry for the trouble caused to you. The URL you have shared is the form edit URL and to use it you need to be logged in to your Jotform account.

    It seems you are not logged in to your Jotform account. Please sign in to your Jotform account and then you will be able to edit the form: https://www.jotform.com/build/92172682145357

    The following guide should help you how to view submissions received in form: https://www.jotform.com/help/269-How-to-View-Form-Submissions

    Hope this helps.

    Do get back to us if you have any questions.

  • Profile Image
    FossielvrijNL
    Answered on August 08, 2019 at 08:02 AM

    Hey Ashwin,

    Thanks for your response. The link you sent gets me a bit further but I still cannot view people's responses. I can click on analytics, then responses, and then when I click on View Response it says I don't have the right permission to view that.


    I think the issue might be that I created the form without having made an account (I was surprised myself that that worked). At first it seemed to work fine but the next day I couldn't view the responses anymore so I created an account, but the weird thing is that the form was not made with any account...

    Any idea how to get around this?

    Warm wishes,
    Fleur


    PS: This might be completely unrelated but none of the links work for me in my firefox browser - so I am using safari in stead. Not a big problem for me but just so you know.

  • Profile Image
    FossielvrijNL
    Answered on August 08, 2019 at 08:03 AM

    PPS: So also when I log into my account it says I have no forms. However, the funny thing is that when I follow the link you sent me it does seem to have the form connected to my account...

  • Profile Image
    Richie_P
    Answered on August 08, 2019 at 09:25 AM

    I have checked your account and it seems form is already in your account.

    May we know if you can't still view the form in your account?

    I have cleared your form cache.

    Kindly check your form again and let us know how it goes.

  • Profile Image
    FossielvrijNL
    Answered on August 08, 2019 at 11:15 AM

    Hello Richie!

    When I log in it still says I don't have any forms in my account. When I go to the link Ashwin sent me (https://www.jotform.com/build/92172682145357) and then to Form Analytics and then Responses I still cannot click View Responses, it says I might not have the right permission.

    So I still cannot access the responses to the survey...


    Warm wishes,
    Fleur


  • Profile Image
    Richie_P
    Answered on August 08, 2019 at 11:33 AM

    When I logged to your account I can view the form.

    Can you please try using another web browser to log-in to your account?

    If the issue still remains, we can try cloning the form instead.

    Guide:https://www.jotform.com/help/42-How-to-Clone-an-Existing-Form-from-a-URL


    Let us know how it goes.

  • Profile Image
    FossielvrijNL
    Answered on August 12, 2019 at 11:10 AM

    Hello Ritchie!

    Thanks for your reply.

    As you can see in the screenshot attached I still cannot see the form in my account. I've tried Firefox and Safari and both don't show the form as part of my account. I did make a clone of the form which you can see on the screenshot below. However, that doesn't really help me since with this form I have still lost the original signups...1565622511Screenshot 2019-08-12 at 17.04

    And on this screenshot you can see what it shows me when I click on the link Ashwin sent me: https://www.jotform.com/build/92172682145357


    1565622562Screenshot 2019-08-12 at 17.05

    Maybe that somehow helps. As you can see I can access the form and it seems to allow me to edit it but when I click on anything it simply brings me back to the first screenshot, which only gives me access to the clone of the form...

    What a mystery.

    Warm wishes,
    Fleur

  • Profile Image
    Richie_P
    Answered on August 12, 2019 at 11:28 AM

    I have escalated your issue to our back-end team for further investigation.

    They will contact you via this thread once updates are available.

  • Profile Image
    FossielvrijNL
    Answered on August 12, 2019 at 11:40 AM

    Thanks Richie :). Have a nice day.

  • Profile Image
    Richie_P
    Answered on August 12, 2019 at 02:49 PM

    Hi FossielvrijNL ,

    We have tried to check the form again and it seems it is in your account.

    May we know if you're using a proxy to login to your account?

    Can you please try to login to your account using this URL https://eu.jotform.com/

    Can you also please try clearing your browser's cache and cookies and start a fresh session?

    Guide:http://www.refreshyourcache.com/en/home/


    Let us know how it goes.