Disable/Activate "Submit" button?

  • Profile Image
    canmom40
    Asked on March 16, 2013 at 08:58 PM

    In testing my form, I find that it gets "submitted" as soon as I hit enter.  I added a required field near the end of the form to keep the form from being submitted by a random "enter", but still, if I hit enter after I fill out that required field, the form gets submitted and the "thank you" screen pops up.  That means the "print" button is gone and, if I (or my users) haven't recorded their price and order info, they have no way to recall it.  

    Is there a way to override this?  Or make the Submit button respond only to a "click" not to "enter"?

    Thanks

  • Profile Image
    EltonCris
    Answered on March 16, 2013 at 11:15 PM

    Hi,

    What browser are you using? Did you embed your form somewhere else? If yes, let us know the website URL so we can check it here, maybe because it was due to a code conflicts.

    Also, how about creating a Hide/Show Condition that displays the submit button once the required field is filled?

    Example:

    Let us know if this doesn't help. Thanks!

  • Profile Image
    canmom40
    Answered on March 17, 2013 at 03:30 PM
    Ha! Sweet! I think that worked.
    I have not put the form anywhere else yet, have emailed a link to myself and have been using that to test the form as I tweek it. I use Chrome, primarily. I guess I'd better check this in IE and Mozilla before I post it to my people.
    Next question, if that's ok:
    Can I make some of the "product" selections active only under certain conditions? ex. "Family" options are only available if "family member" field is filled.
    Thanks again!
    Maureen
  • Profile Image
    Welvin
    Answered on March 17, 2013 at 03:53 PM

    Hi Maureen,

    You may reversed what you are thinking to make it possible, Show the Family Options once Family Product is selected. You can apply the "Rule" in the Product Field. Still using the Show/Hide a form field condition.

    Just try it and let us know if you need help with the setup.

    Thanks