I'm having trouble changing the email notifications

  • Profile Image
    grover08
    Asked on March 18, 2013 at 12:24 PM

    I cloned one of my forms and made some changes to it.  I changed my email address in my account settings and made new email notifications for the new form yet when sending test forms they are still being sent to my old address. Any help would be much appreciated. Here is the form. 

    http://form.jotform.us/form/30764954746163

     

    Thanks!

    Laura

  • Profile Image
    glennlee
    Answered on March 18, 2013 at 12:36 PM

    Hi,

    I checked your form and I did not see any notification settings. Here is a video tutorial on how to set up email notification.

    Note: If your email address in notification is not the account's primary email address, test it on preview mode. Test email button will only work for account's primary email address.

    Thanks

  • Profile Image
    grover08
    Answered on March 18, 2013 at 12:44 PM

    Oh, sorry, I deleted the notifications and logged out then forgot to redo them when I logged back in.  I have re-entered an email notification and it still goes to my old address even though the new address associated with my account is on there.  Thanks again!

  • Profile Image
    Goldo
    Answered on March 18, 2013 at 12:59 PM

    Are you using the test button? If yes, then it will send the notification email to your account email address and not what's entered on the email notification settings.

    The only way to test if it really is working is to manually fill it out. I have filled out the form, are you able to receive a notification?

     

     

  • Profile Image
    grover08
    Answered on March 18, 2013 at 01:06 PM

    yes, I'm using the test button but I've changed my account email address to my new email so the old email address is nowhere on the site yet it still goes there.

    I saw that you filled out the form, thank you.  It showed up in my yahoo account but ended up in the spam folder of the new account.  As long as it shows up in the new account I'm fine with it & will make adjustments for the spam folder.  It's confusing though as to why when I send a test form it goes to the old account.  Just one of those things I guess.  Thanks again for your help.