I am getting 404 error when using Custom Thank You URL

  • Profile Image
    ilybean
    Asked on September 05, 2019 at 09:51 AM

    My form is https://www.jotform.com/build/92374949003461/

    on submit lot of empty space is there so user cannot see thank you message so i thought that i should redirect it to a different url. but when i gave https://ilybean.com/pages/thank-you and when form submits it throws 404 error, why does this happen?

    one more question if we redirect to different url then on submit form i am using zapier to pass values to klaviyo, will that thing still happen?

  • Profile Image
    Welvin
    Answered on September 05, 2019 at 11:26 AM

    Your custom thank you URL is working to my end. I can only tell that you have maybe incorrectly pasted the link. You should include https:// and not just www in the URL. Please add that again and let us know if the issue persists. 

    Yes, Zapier should still work. 

  • Profile Image
    ilybean
    Answered on September 05, 2019 at 11:39 AM

    i had pasted complete url of thank you page along with https but it resulted in 404

  • Profile Image
    Welvin
    Answered on September 05, 2019 at 12:07 PM

    My apologies. I get it now. However, this is because of the Send Post Data that you have enabled in the form settings. Are you processing anything on the thank you page URL - like displaying the form data?

    You do not need to enable this option if you are not sending the form data to an external page or when not required by a third-party service provider.

    I turned off send post data for you. Please try again. 

  • Profile Image
    ilybean
    Answered on September 05, 2019 at 03:24 PM

    Thanks