What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Trouble with form display in Internet Explorer

    Asked by amsweb1 on March 22, 2013 at 12:16 PM

    Hello -

    We have been having trouble with users getting a blank screen on the JotForm we are providing them.  It somtimes happens on the home screen, other times it occurs 2-3 pages in (it's a multi-page form).  I believe in all cases, it's been in Internet Explorer.  It may or may not have to do with mixed content as that pop-up does come up, but even when we select ALLOW, it doesn't show the form fields.  Only the form title bar and a blank page?

     

    The form is at http://www.jotform.com/form/20321517310 and it can also be accessed by clicking on the Register link at the URL provided below. 

    http://www.gemgreyhounds.net/greyhound-event-michigan/

    Page URL:
    http://www.gemgreyhounds.net/greyhound-event-michigan/

  • Profile Image

    Answered by KadeJM on March 22, 2013 at 01:07 PM

    I think I may have replicated the problem in IE8 on Windows XP. It seems to be an issue only with an older outdated browser and from what I know IE is devious for problems in older versions as in more recent versions of IE to the latest I was not able to reproduce it. It looks like the brower's popup was is failing to recognize the lightbox even after allow has been selected. 

    Have you tried disabling your pop-up blocker to see if the same problem occurs?

    Also you may want to try turning off add-ons and test that way too.

  • Profile Image

    Answered by amsweb1 on March 22, 2013 at 04:33 PM

    Unfortunately I myself have been unable to replicate the issue, but I know I can't expect our visitors to go through these things.  Is there something particular in the form that is causing this issue or do all JotForms experience this issue in IE when certain browser configurations are consistent?

  • Profile Image
    JotForm Support

    Answered by jonathan on March 22, 2013 at 06:19 PM

    Hi,

    The form embedded in your website is using the secure(https) URL version. While your website itself is not using SSL or https protocol.

    This is the reason why the security message warning pop-up on some browser.

    <script type="text/javascript" src="https://static-interlogyllc.netdna-ssl.com/min/g=feedback2">//

    <![CDATA[new JotformFeedback({ formId:'20321517310', base:'https://secure.jotform.com/',

     

    Please generate the embed code again in JotForm, and use only the regular URL version (do not use secure URL)

    Inform us the issue persist after doing this.

    Thanks.

  • Profile Image

    Answered by amsweb1 on March 22, 2013 at 07:21 PM

    Whether or not I select SECURE FORM, it uses the same https://secure path...

  • Profile Image
    JotForm Support

    Answered by jonathan on March 22, 2013 at 07:57 PM

    Can you please try manually editing the code before you embed it?

    Change the https://secure path to  http://www instead... like this code

     

    <script src="http://www.jotform.com/static/feedback2.js?3.1.2322" type="text/javascript">

    new JotformFeedback({

    formId:'20321517310',

    base:'http://www.jotform.com/',

    windowTitle:'Membership Registration',

    background:'#5234D9',

    fontColor:'#FFFFFF',

    type:false,

    height:500,

    width:700

    });

    </script>

     

    Please update us if this still does not work for you.

    Thanks.

  • Profile Image

    Answered by amsweb1 on March 22, 2013 at 09:00 PM

    I have updated the code manually, let me know how it looks there in IE8.

     

    <script type="text/javascript" src="//www.jotform.com/static/feedback2.js?3.1.2322">

    // <![CDATA[

    new JotformFeedback({ formId:'20321517310', base:'http://www.jotform.com/', windowTitle:'Event Registration', background:'#5234D9', fontColor:'#FFFFFF', type:false, height:500, width:700 });

    // ]]>

    </script>

  • Profile Image
    JotForm Support

    Answered by jonathan on March 22, 2013 at 09:15 PM

    Hi,

    I was able to reach the paypal payment screen properly after submitting your form using your website page.

     

    Although I did noticed in your form that the payment field is not set to required. So, users will be able to submit the form without any payment also. I thought I should let you know that, just in case you just miss it.

    Contact us again anytime should the problem persists.

    Thanks.

  • Profile Image
    JotForm Support

    Answered by jonathan on March 22, 2013 at 09:20 PM

    Also, you should update your custom Thank You page. It only return a Page Not Found page

    http://www.gemgreyhounds.net/thank-you-2/

     Thanks.

  • Profile Image

    Answered by amsweb1 on March 22, 2013 at 09:36 PM

    Thank you for the help and the extra tips!

  • Profile Image

    Answered by amsweb1 on March 29, 2013 at 09:13 PM

    This issue is continuting to surface.  There is no consistency in OS or browser.  But it's becoming a big problem.  Below is a notification we received from just one user today.  Please advise what else we can do.  This is an annual event, last year we had no problems with the form... this year too many.

    "I have been trying this morning to register for the GEM event but when I put in the information on the first page and hit next nothing happens except it tells me there is an error on the page!"

  • Profile Image

    Answered by jefreylandicho on March 29, 2013 at 11:14 PM

    I was unable to reproduce the same issue as well however please try to remove the 2 after the feedback word. The script should look like below

    <script type="text/javascript" src="//www.jotform.com/static/feedback.js?3.1.2322">

    Also try replacing the email standard field with the email field under Quick Tools.

  • Profile Image

    Answered by amsweb1 on March 30, 2013 at 07:59 AM

    Ok, I made the change to remove the number "2", but I did not change the e-mail field, as I don't want to lose the data we collected on the current one.  Maybe you can make that change and associate the data back to the new field?

  • Profile Image
    JotForm Support

    Answered by Welvin on March 30, 2013 at 10:09 AM

    Hi,

    That's right. Please do not delete the email field to avoid lost of data for that particular field. I'd suggest you to clone the form, do the changes on this cloned form and use it instead. Embed the form and remove number "2" from the given codes before placing that on your website.

     

    Thanks

  • Profile Image

    Answered by inspect2015 on March 22, 2017 at 03:28 PM

    I am running into the same type of issue with a form not opening properly in IE but if I open in another browser such as Firefox it works. I have embedded the form into my website any suggestions have to fix the issue.

     

    http://mohawkind.com/Inspectorform.aspx

     

  • Profile Image
    JotForm Support

    Answered by Welvin on March 22, 2017 at 05:47 PM

    @inspect2015: I have created a new thread for your problem. You will be answered there. Link: https://www.jotform.com/answers/1099239