Encrypted forms unable to submit - stuck on please wait message

  • Profile Image
    Natasha
    Asked on September 12, 2019 at 10:07 PM

    Hi 

    I have a form I currently use to collect personal details for new staff. This form has been working well for many years but stopped working yesterday.  I have tried to trouble shoot the problem and found that if I turn off the form encryption I can get submission through. I really want to have the forms encrypted so I am hoping you can advise how to resolve this problem.

    Thanks

  • Profile Image
    JohnRex
    Answered on September 12, 2019 at 11:51 PM

    I made a test submission to your form and was able to reproduce the issue. The form did not submit and was stuck to Please wait... status only.

    15683459201962726.png

    I also cloned your form, enabled form encryption and used a new key but still the error occurs:

    15683466351962726 2.png

    Let me escalate this to our backend team so they could take a closer look at the issue. Rest assured that we'll keep you apprised as soon as updates are available.

  • Profile Image
    JohnRex
    Answered on September 12, 2019 at 11:58 PM

    I also tried encrypting one of my forms other than the clone but was not able to replicate it. So the issue happens only with your form.

    Let us wait for insights from our developers as to what transpires.