Feedback button in IE is not working as intended

  • Profile Image
    mhdeals
    Asked on March 24, 2013 at 04:19 PM

    having problems getting this JOTFORM to work across platforms. It gives different results and behaviors on different browswers for instance on IE in some cases it is unclickable. In others it is turned the wrong way for instance it portrays as a horizintal tab poking out from the side as opposed to a verticle tab on the side. There are different reaction to WP vs Gallery as well.

     

    Its got bugs...

     

    Website is MHdeals.net and mhdeals.net/gallery I use WP and Gallery.

  • Profile Image
    jonathan
    Answered on March 24, 2013 at 05:17 PM

    Hi,

    Base on my test so far, I could not reproduce the issue you showed on your screenshot.

    On my end using IE, it looks like this.

    Can you please try also clearing your browser cache. It might help make the difference.

    I will do further check. I will get back to you in a while for the results.

    Thanks.

  • Profile Image
    jonathan
    Answered on March 24, 2013 at 05:27 PM

    I tried on another hardware with all different set of OS configuration, I still could not produce the same issue you had.

    Can you also share to us your OS configurations. Which browser, OS versions are you using.

    Thanks.

     

     

  • Profile Image
    mhdeals
    Answered on March 24, 2013 at 05:48 PM

  • Profile Image
    jefreylandicho
    Answered on March 24, 2013 at 05:55 PM

    We are unable to see your response, please try reposting you response using the link below.

    http://www.jotform.com/answers/196406-Feedback-button-in-IE-is-not-working-as-intended#3

    Thank you.

  • Profile Image
    mhdeals
    Answered on March 24, 2013 at 06:01 PM

    http://mhdeals.net/?p=2747

     

    I use win7 ultimate 64

  • Profile Image
    jonathan
    Answered on March 24, 2013 at 06:42 PM

    OK. It seems I found the correct page you are refering to.. this page http://mhdeals.net/gallery/

    The feedback button was at the bottom because it was what your feedback code is setup to.

    I suggest you gather again the feedback button code from Jotform and re-embed it in your page. 

    Please update us of the results.

    Thanks.

  • Profile Image
    mhdeals
    Answered on March 24, 2013 at 07:33 PM
  • Profile Image
    mhdeals
    Answered on March 24, 2013 at 07:43 PM

    http://mhdeals.net/wp-content/uploads/2013/03/JotForm-IE10-coded-for-center-left-shows-sideways-tab-works-ok.png

     

    IE 10 is thecurrent browser verion I am using

     

    HP elitebok with win7 ult 64

  • Profile Image
    jonathan
    Answered on March 24, 2013 at 07:51 PM

    Can you please try this code instead. If you could have generated again the feedback code, it should have been like this.

     

    <script src="//www.jotform.com/static/feedback2.js?3.1.2332" type="text/javascript">

      new JotformFeedback({

         formId : "30774932990868",

         buttonText : "MHDEALS CONTACT",

         base : "http://www.jotform.com/",

         background : "#7F00FF",

         fontColor : "#FFFFFF",

         buttonSide : "left",

         buttonAlign : "center",

         type : false,

         width : 380,

         height : 575

      });

    </script>

     

    Please try this. And I will test also.

    Thanks.

  • Profile Image
    mhdeals
    Answered on March 24, 2013 at 10:38 PM

    I placed the code you gave me. No change. Do you need another screenshot?

    http://mhdeals.net/wp-content/uploads/2013/03/JotForm-IE10-coded-for-center-left-shows-sideways-tab-works-ok1.png

  • Profile Image
    jonathan
    Answered on March 25, 2013 at 01:04 AM

    Hi,

    Thank you for updating us.

    I guess there is no need for the screenshot since I could also see already how it is on my end. And I can see the code that you have used by viewing your page source code.

    I was able to reproduce this problem also only on IE9 browser but not on any other browser. Same as you, I was able to test on Win 7 OS (32 and 64 bit versions)

    --

    Can you also try first the solution offered on this thread.

    Particularly this one:

    -------------------------------------------------

    The function


    <script type="text/javascript"> $.noConflict();</script>

    Should be right before , the  code of the feedback form :

    Make also sure you remove the number, so the code should look like this:

    <script src="//max.jotfor.ms/min/g=feedback" type="text/javascript"> new JotformFeedback({ formId : "30205084396956", buttonText : "HHPage Website Inquiry", base : "http://jotformpro.com/", background : "#F59202", fontColor : "#FFFFFF", buttonSide : "left", buttonAlign : "center", type : 1, width : 700, height : 500 }); </script>
    -------------------------------------------------------
    Please try if OK, and I will test again.
    Thanks.