Embedded form: Form hangs on 'Submit'

  • Profile Image
    WoolamaiBeachSLSC
    Asked on September 20, 2019 at 07:41 PM

    https://form.jotform.co/91583263384867

    Published at:

    https://www.woolamaibeach.org.au/calendar/60th


    Multiple customers have reported the form does not submit

  • Profile Image
    gerardw
    Answered on September 20, 2019 at 08:25 PM

    I checked the webpage where you have embedded the form and the Submit button stays on "Please wait". I can see that you have embedded the form using the iFrame code.

    Since when are you facing this issue? I was able to replicate this on your standalone form also. It returned an error on the console.

    It appears to be an issue with the Square payment field. Please try to reintegrate the Square payment field in the form and let us know if the issue is persisting.

  • Profile Image
    WoolamaiBeachSLSC
    Answered on September 20, 2019 at 08:55 PM

    Thank for that. I've replaced the embedded form with a new, makeshift one to get by. I'll replace the Square integration  and see how it goes.


  • Profile Image
    WoolamaiBeachSLSC
    Answered on September 22, 2019 at 02:33 AM

    @gerardw

    I’ve reconnected the Square integration; customers still reporting the Submit button hangs on ‘Please wait ...’ for 10 minutes. 

    Please evaluate at the Jotform link. I’ve replaced the embedded iframe form with a placeholder so we’re not losing customers meantime, but the busted original is integrated with a Google Sheets doc of data, so it’d be an inconvenience to have to kick it and start over. 

  • Profile Image
    roneet
    Answered on September 22, 2019 at 03:24 AM

    Could you please clear your browser cache to see if this resolves the issue?

    https://www.refreshyourcache.com/en/home/

    When I tested the Form, I was unable to replicate any issues with it as I was getting an Invalid Card error which means we are getting a response from the payment integration.15691369341.PNG

    Let us know if you are still experiencing the issue.

    Thanks.