Having problems connecting Jotform to Stripe

  • Profile Image
    survivalskills
    Asked on October 18, 2019 at 09:18 AM

    I'm trying to connect a form to my payment processor, Stripe. 

    Stripe is successfully connected with other gateways, but it's stuck with Jotform. 

    I'm getting a message with says: 

    https://www.jotform.com/server.php?action=stripeConnect&scope=read_write&code= etc

    Successfuly logged in
    to your Stripe accounts,
    please wait...

    Successfully being spelled wrongly is a bit worrying, and all I'm seeing is the timer - the page never goes anywhere.

    Any clues where the problem is?

     

    Screenshot
  • Profile Image
    Victoria_K
    Answered on October 18, 2019 at 09:52 AM

    Hello, 

    I think your browser may be blocking the connection process. Do you see any blocked popups in the address bar? Would it be possible for you to share a full screenshot of a browser window so we checked closer? 

    Regarding spelling issue, I will pass your concern to our development team and they will apply a fix. Thank you for bringing this to our attention. 

  • Profile Image
    survivalskills
    Answered on October 19, 2019 at 06:58 AM

    I've tried it on two PCs (Win 7 and Win 10) in two different browsers (Edge and Chrome) with all adblockers turned off. It still hangs on the 'please wait' message.

    I've also installed the Jotform Android app on the phone and tried logging in from there. Exactly the same problem. 

    If I allow all cookies including third party cookies - thus essentially turning off all privacy settings - then the Stripe pop-up appears, but when I click on 'connect' the pop-up window instantly closes and I'm back to showing 'Connect with Stripe' in the form builder window. 


  • Profile Image
    VincentJay
    Answered on October 19, 2019 at 09:29 AM

    Thank you for testing.

    Is there a way you could test the integration using a different internet network or connection? 

    I tested the integration and it is working fine on my end. I cleared your form cache on our server. Please see if that helps. 

    We'll wait for your reply.

  • Profile Image
    survivalskills
    Answered on October 20, 2019 at 04:55 AM

    I've linked another third party app to Stripe, so the problem doesn't seem to be at Stripe's end.

    I've also tested on the phone using mobile data - bypassing my wifi network in other words - and the request gets handed to Stripe, I'm able to log in with my account details, and I get returned to the Jotform page where I'm still getting stuck with the 'successfully logged in... please wait' message.

  • Profile Image
    Victoria_K
    Answered on October 20, 2019 at 06:02 AM

    Hello,

    Could you get a screenshot of console report from your browser at the moment when issue takes place? 

    Here is a guide: How-to-get-a-console-report-from-most-common-browsers

  • Profile Image
    survivalskills
    Answered on October 22, 2019 at 07:05 AM

     I'm out of the office for a couple of days, I'll get this information as soon as I can.