What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    required fields do not work on my site! HELP!!!!!

    Asked by leonidbilchenko on April 17, 2013 at 05:02 AM

    Hello!

    I have a problem with required fields. They do not work.

    I downloaded the source code of my form with the scripts and CSS, and installed on the site, but the required fields are not working.

    So I used an empty file html-file, conflict with the script should not be.

    What's the problem? Maybe that in the settings? But the form works fine on the original link for your service.

    Page URL:
    http://eesummit.bilchenko.info/ee-summit2013.html

    Screenshot
    site problem source settings
  • Profile Image

    Answered by sidharth_kch on April 17, 2013 at 08:07 AM

    @leonidbilchenko

    When you downloaded the source code, "js" and "css" folder must have been downloaded. Please upload these folders to the same location where you have uploaded your html file.

    This should resolve your issue. Let us know if you continue to have this issue.

    Thanks,

    Sidharth

  • Profile Image

    Answered by leonidbilchenko on April 22, 2013 at 12:34 PM

    Today I tried. But still not working.

    http://ee-summit.org/registr/ee-summit2013.html

  • Profile Image

    Answered by sidharth_kch on April 22, 2013 at 01:03 PM

    @leonidbilchenko

    I checked your code and if you have copied your form's code in empty html file, why do you have jquery and other js files reference in your code.

    <script src="js/vendor/jquery-1.8.0.min.js?v=3.1.230" type="text/javascript"></script>

    <script src="js/vendor/maskedinput.min.js?v=3.1.230" type="text/javascript"></script>

    <script src="js/vendor/autoFill.min.js?v=3.1.230" type="text/javascript"></script>

     

    Please remove these lines form your code and see if you continue to have this issue.

    Thanks,

    Sidharth

  • Profile Image

    Answered by leonidbilchenko on April 22, 2013 at 02:26 PM

     

    I downloaded a folder at this link.

    Put it in the root of the site. That's it.

    That is, in fact I downloaded the non-working code.Because the required fields are not working.

  • Profile Image

    Answered by leonidbilchenko on April 22, 2013 at 02:36 PM

    Also, I tried to remove those scripts that you have indicated, but required fields still do not work.

  • Profile Image

    Answered by sidharth_kch on April 22, 2013 at 02:53 PM

    @leonidbilchenko

    Yes i checked that myself. I see that there is a CSS file missing when you download the source code. 

    I am creating a ticket and forwarding your issue to our development team so that they can have a look.

    Please stand by for updates from them.

    Thanks,

    Sidharth

  • Profile Image

    Answered by leonidbilchenko on April 22, 2013 at 02:56 PM

    OK, thank you!

  • Profile Image

    Answered by leonidbilchenko on April 22, 2013 at 02:57 PM

    I hope it will not be too long, as I will soon start registration.

  • Profile Image

    Answered by leonidbilchenko on May 04, 2013 at 07:32 AM

    What about my question?

    No one takes the time to answer me?

  • Profile Image

    Answered by pinoytech on May 04, 2013 at 10:03 AM

    @leonidbilchenko

    This issue is already assign to one of developer and doing his best to fixed this immediately. Don't worry, as soon as this issue sorted out, we will inform you immediately.

    Thank you for you patience!

  • Profile Image
    JotForm Support

    Answered by alp_deniz on May 22, 2013 at 08:45 AM

    I could not replicate the problem. It works like charm! Do you also confirm?

  • Profile Image
    JotForm Support

    Answered by kenneth on November 09, 2013 at 08:30 AM

    Hi it seems that the problem are missing files. Have you tried this again? you still be able replicate the problem? We have made a fix on this last month. Hope that its now fixed on your side.

    Thanks,
    Kenneth