Form submits without asking for required fields.. refresh also resends email.

  • Profile Image
    rhormazar
    Asked on May 24, 2010 at 09:01 PM
    for some reason hitting submit form doesn't validate that all the required fields are filled.. also hitting refresh after sending a form re-sends the email.
  • Profile Image
    aytekin
    Answered on May 25, 2010 at 01:25 AM
    Can you send us the URL of the form that has this problem? Please also describe which fields are not validated.
  • Profile Image
    rhormazar
    Answered on May 25, 2010 at 01:06 PM
    needagent.us is the webiste. if you click in and out of the field is asks for them.. but if you dont touch anything  and just hit send, it just sends it blank
  • Profile Image
    aytekin
    Answered on May 26, 2010 at 03:59 AM
    Just tested it and it asked me to enter the required field. Have you already resolved this problem  by updating the form code on your site?

    If it only happens on one of the browsers the page probably have a javascript error that prevents the required fields. Try updating the form code on your site.
  • Profile Image
    rhormazar
    Answered on May 26, 2010 at 04:21 PM
    did you try submit it without touching any field of the form? and what do you mean by "updating the form code"? i took the script directly from jotform and applied it in the website. the website itself does not contain any javascript, and since i only took the script from jotform i havnt manipulated any of it.
  • Profile Image
    aytekin
    Answered on May 27, 2010 at 07:55 AM
    If I try to submit the form without filling any field I get error message and it asks me to complete the required fields. I use Firefox on Mac OS X.
  • Profile Image
    rhormazar
    Answered on May 27, 2010 at 01:06 PM
    yes, i see it working in firefox and internet explorer.. not in chrome. i'll see if it gets fixed if i put all the javascript and css in the document instead of having it linked.

    btw i need to change the billing information. i already read about Plimus, but i dont have the username.. please cancel my account so i can change the information when it requests re-subscription 
  • Profile Image
    aytekin
    Answered on May 28, 2010 at 03:36 AM
    OK, I see the problem on Chrome.

    I added this to our bug list. We will look into it.
  • Profile Image
    seyhuns
    Answered on July 12, 2010 at 09:04 AM

    Hello rhormazar,

    We have fixed your problem and it's working now. Please check your form again.

    Thank you.