Conditions Previously Working

  • Profile Image
    ipgflorida
    Asked on April 24, 2013 at 10:28 AM

    Hi,


    If you look at my form conditions you can easily see that my form is messed up. If the "who did you book with" is blank it needs to display everything, except for the "since you have booked message".

    When the "who did you book with" is blank it should display all of the forms except for the "since you have booked with" message. If you click "other" it should only display the "since you have booked" message. Besides that when you click "direct booking" or "tour operator" it works fine.

    Why is my form messed up with the conditions?! Please look at the conditions and you will see that it is messing up. It looks like that there was an update for Jotform, and that seems to have messed up the conditions. How do I fix this ASAP?

    I need this fixed as soon as possible!

    Found below is the URL to my form:

     

     

    http://form.jotformpro.com/form/30925793485971

  • Profile Image
    jeanettebmz
    Answered on April 24, 2013 at 11:38 AM

    Were these conditions were working ok before? Apparently this was the situation. We will make our tests and will escalate the problem if necessary

  • Profile Image
    jefreylandicho
    Answered on April 24, 2013 at 11:50 AM

    Please try editing condition two as shown below. 

    I created a clone form in your account for your reference called 'Working Clone of Check In Form' (view form).

    I have also escalated this thread to our developers for further investigation why the form condition suddenly stop working. 

  • Profile Image
    ipgflorida
    Answered on April 24, 2013 at 11:57 AM

    Hi,

    I appreciate all of your help, and how quickly you helped. I have resolved much of the issue, but now it really revolves around when somenoe clicks "other (third party website...)" on "who did you book with?", it is only supposed to show the message, but for some very odd reason it is showing my products, and other items as well.

    These exact same fields are supposed to be HIDDEN but only for when someone selects "direct booking" under "who did you book with?".

     

    Can you please see why this is happening? Everything else is working fine now, I just had to completely re-adjust my conditions.

    I appreciate all of your help!

    Thank You

     

    J. Greene

  • Profile Image
    jefreylandicho
    Answered on April 24, 2013 at 12:26 PM

    In your 3rd condition, please add a new rule as shown in the highlighted image below.

    Then create a New Condition similar to the image below if you need to remove the lines. You can optionally remove the line5 since it is already set hidden in the condition above.

    Click here to view reference form.

  • Profile Image
    abajan
    Answered on April 24, 2013 at 12:36 PM

    @ipgflorida

    Was it your intention to allow users to select more than one option in the Who did you book with? field? Because that's what check boxes do. I'm wondering if radio buttons won't be a better choice. Please see Checkboxes vs. Radio Buttons.