What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Stuck "Inject Custom CSS" field in Preferences

    Asked by sagemeente on April 10, 2011 at 08:22 PM

    Hi there,

    I have successfully changed the Inkject Custom CSS of my form earlier today. When I have tried to change it again, the field seems to be "stuck". And I cannot edit the field anymore.

    Please see attached screen shot.

    Can you please help?

    Thanks,

    Henry

    Screenshot
  • Profile Image
    JotForm Support

    Answered by liyam on April 10, 2011 at 09:55 PM

    Hello Henry,

    When you say "stuck", do you mean you could not change the values of the CSS injection?

    If so, you will need to click the value properly once so that it can change into a small text area.  You will notice the font change once it is editable.

    Hope this helps.

  • Profile Image

    Answered by sagemeente on April 11, 2011 at 06:50 PM

    Hi Liyam,

    That's exactly my problem. When I click on the value area (as indicated with the red arrow) it doesn't change to the editable text. It just stays as it is i.e. becomes stuck... sort of un-clickable...

    any ideas?

  • Profile Image
    JotForm Support

    Answered by NeilVicente on April 11, 2011 at 07:16 PM

    Hey Henry,

    I've tried accessing your account and that particular form in question and I had no problems whatsoever in editint the inject custom css field.

    Have you tried changing browsers? I can't really say that it is javascript that's causing the problem because I also did try disabling javascript but I was still able to edit the field.

    You may also delete your browser's cache (press shift-ctrl-delete keys at the same time) and see if it helps. Get back to us if problem still persists.

  • Profile Image

    Answered by G3Tech on April 27, 2011 at 01:46 PM

    I had the same problem.  I was beginning to think that "inject" was like an injection that can't be taken out!  I could change any of the other fields on that preferences screen but not inject css.  Clearing the cache, closing the page didn't help. 

    The solution in my case was to turn on compatibility view (Alt (if your menu isn't on) - Tools - Compatibility view).  Now it works.  I'm using IE 9 ver 9.0.8112.16421. 

    GGG

  • Profile Image
    JotForm Support

    Answered by NeilVicente on April 27, 2011 at 01:51 PM

    @G3Tech

    Thank you for sharing your insights in this issue. The original poster was indeed using IE9 as well when this happened. If he could read this, I'm pretty sure he'd be thankful as well. We at Jotform Support Team appreciate your efforts.

    Regards,
    Neil