A user is unable to access the embedded form due to the error: "ERR_SSL_VERSION_OR_CIPHER_MISMATCH"

  • Profile Image
    swanseacc
    Asked on January 12, 2020 at 06:28 AM

    Hi,
    A user cannot access the form, any advice Please?
    I send the website form address link:
    https://form.jotformeu.com/83131103536344
    but when they click it, this comes up:
    'This site can’t provide a secure connectionform.jotformeu.com uses an
    unsupported protocol.
    ERR_SSL_VERSION_OR_CIPHER_MISMATCH
    Unsupported protocol
    The client and server don't support a common SSL protocol version or cipher
    suite.'

    Do you have any advice please?

    Thank you! :-) 

  • Profile Image
    roneet
    Answered on January 12, 2020 at 08:26 AM

    Have you embedded the Form on any website? If yes, please share the URL of the website.

    The direct link of the form could be accessed and loaded successfully.

    Is this issue related to a single user or multiple users getting the same error?

    We are waiting for your response.

    Thanks.


  • Profile Image
    swanseacc
    Answered on January 12, 2020 at 11:15 AM

    Hey,
    As far as I'm aware, it's one user, and the form is embedded in a private member's area on our club website, but all members also have the weblink.

    Thank you!

  • Profile Image
    BDAVID
    Answered on January 12, 2020 at 12:52 PM

    Usually, the "ERR_SSL_VERSION_OR_CIPHER_MISMATCH" shows up when you try to load an insecure site. Is your site using the SSL secure protocole?

    Please note that our form links and embed codes are secure by default(https), so if a secure form is embedded in an insecure site, it can produce a mismatch error.

  • Profile Image
    swanseacc
    Answered on January 13, 2020 at 04:18 AM

    Hi, Our user is only using the direct https weblink, not the embedded code on our website.

    Any ideas please?

    All other users are not having any access problems either through our website or direct browser link!

    Thank You for trying to help us! :-) 

  • Profile Image
    Richie_P
    Answered on January 13, 2020 at 07:21 AM

    The issue could be your anti-virus is blocking the load of JotForm.

    Can you please try to disable your anti-virus and let us know if the issue still remains?