Trouble embedding in iFrame on Facebook

  • Profile Image
    bryanzane
    Asked on April 10, 2011 at 10:39 PM

    I'm having trouble with a form when I embed it in an html document that is then being used on Facebook.  I'll go through the steps that I have:

    1) the form goes into my page fine and displays fine.

    2) the input and submit mechanisms work perfectly.

    3) after submitting the form they are directed to a custom thank you page created in JotForm.

    4) on the custom thank you page I have 2 links.  Neither of the links open within the iFrame and it's a huge problem. 

    Does anyone have any idea how I can fix this? I tried building a seperate thank you webpage that does the same thing as the custom thank you, but that ALSO opens outside the Facebook iFrame...

    Help. please.

  • Profile Image
    bryanzane
    Answered on April 10, 2011 at 11:54 PM

    Also, that form is not live.  I will not give out any information that is entered in any field.  You have my word as a gentleman.

  • Profile Image
    allanftd
    Answered on April 11, 2011 at 04:05 AM

    Hi bryanzane,

    Thanks for posting your concern here. Regarding your case, the following thread may give you a solution:

    http://www.jotform.com/answers/15186-Custom-thank-you-page-in-iframe?entrymessage=10732640770

    Some solutions mentioned there apply only to default the Thank You page.

    Another solution that I could think of is to get the two links to open in a new window or tab (if that is acceptable for you). Add to the anchor tag so that it becomes:

    <a target="_blank" href="http://www.mywebsite.com" rel="nofollow noopener" >click here</a>

    We hope this information will be helpful. Let us know if you need further assistance.

    Thank you for using JotForm!

    JOTFORM SUPPORT