Save and continue later is not working

  • Profile Image
    bftdata
    Asked on January 22, 2020 at 07:37 AM

    Hi there,

    I'm just about to launch a couple of forms today, and have discovered that the save and return functionality is not working. It worked fine when I tested it earlier in the design process. Can you help to work out what's going on?

    I have Form 1 - 'eligibility form' (https://form.jotformeu.com/93374542858368)

    linking to Form 2 - 'Box scheme application form' (https://form.jotformeu.com/93374691627367)

    I followed the instructions from your support page. I have also added in some extra code to pre-populate some of the answers from Form 1 into Form 2.

    Is there a simple error here? How can I get the save and return function working again?

    Thanks a lot,

    Rob Alderson

  • Profile Image
    Jed_C
    Answered on January 22, 2020 at 08:56 AM

    I tried your form and the code generated in your thank you page fills the information to this form https://form.jotformeu.com/93374691627367.

    Here's a sample URL generated with the session link https://form.jotformeu.com/93374691627367?session=jed@jotform.com?nameOf11=Test&postcode=asdf&contactName14=asdf&contactPhone15=123123&emailAddress=jed@jotform.com&whatYear358=123&whatWas=123&whatAre339=123.

    Can you please try accessing that and try saving the changes and see if it changes the value.

    Looking forward for your response. 

  • Profile Image
    Jed_C
    Answered on January 22, 2020 at 08:59 AM

    I also found that you need to use eu.jotform.com in your url.

    ex.

    https://eu.jotform.com/93374691627367?session=jed@jotform.com

    That should save the session if you use eu.jotform.com. Please try that and let us know how it goes.

  • Profile Image
    bftdata
    Answered on January 22, 2020 at 01:04 PM

    Hi Jed,

    thanks for your help. I have clicked on your link, made some edits, clicked out and clicked in again and the changes were not saved.

    I also changed the URL as you suggested, and it still doesn't work.

    So it's all still not working. Any other ideas?

    Thanks,

    Rob

  • Profile Image
    bftdata
    Answered on January 22, 2020 at 03:15 PM

    Hi again,

    There's a bit of urgency to my query, as these are public-facing forms that should be launching today - is it possible to prioritise this query?

    Many thanks,

    Rob

  • Profile Image
    Welvin
    Answered on January 22, 2020 at 05:25 PM

    It worked for me.

    https://eu.jotform.com/93374691627367?session=welvin@jotform.com&nameOf11=Jotform&postcode=94111&contactName14=Welvin&contactPhone15=1234567878909&emailAddress=welvin@jotform.com&whatYear358=2011&whatWas=12000&whatAre339=120

    Please note that the Next button should be clicked to save. If you only changed the first page and did not click the next button, no changes are saved for that. Every change, the next/back button are required to be clicked to save. You may consider adding a note on the top of the second form regarding this matter. 

  • Profile Image
    bftdata
    Answered on January 23, 2020 at 05:17 AM

    Hi there,

    thanks for the reply. In the URL link I have made one change:

    From: https://eu.jotform.com/93374691627367?session={email19}? ...

    To: https://eu.jotform.com/93374691627367?session={email19}& ...

    And that seems to have worked.

    The main issue I have is that when I make changes to the Thank You page - where one of these URL links is - the changes don't seem to save properly. I will go back later in the day and see that the changes haven't stayed, for some reason. This includes other changes I made to the Thank You page, including altering an image.

    I have made the same changes over 5 times. They look to have stayed changed now, but is there any explanation for this? Am I doing something wrong when I edit the Thank You page? Unlike the Autoresponder email editing page, there isn't a 'Save changes' button to press on the Thank You page - could be a useful thing?

    Thanks,

    Rob


  • Profile Image
    Richie_P
    Answered on January 23, 2020 at 05:46 AM

    You may try clearing your browser's cache 1st and then login back to your account to edit your thank you page.

    It could be that the system has logged you out when you were editing your form.

    Let us know if the issue still remains and kindly share a screenshot.

    Guide:-How-to-add-screenshots-images-to-questions-to-the-support-forum

  • Profile Image
    bftdata
    Answered on January 23, 2020 at 06:25 AM

    Thanks Richie, that sounds like a good idea. I'll try that when I'm next making edits.

    Thanks again,

    Rob