Spinner Field: Field is not included in email when it has 0 as default value.

  • Profile Image
    murcielago
    Asked on January 27, 2020 at 06:00 PM

    Hi. Yes these are the fields which are not working. 

    form looks like this:

    1580159600Selection_015.jpg

    if luggage (Small and Large) are left at zero, they are skipped in notification email (which shouldn't happen as they are pre-polulated with number zero and therefore are not empty).  

    1580159690Selection_014.jpg

    (Template looks like this): 


    1580159728Selection_012.jpg



    If I insert 1 large and 1 small pieces of luggage in the spinners,

    1580160169Selection_017.jpg


     then these are correctly reported in notification email. 

    1580159874Selection_016.jpg


    I don't understand why notification email template is behaving like this. I already tried creating new template and creating new spinners for luggage but I get the same error (number zero in these spinners is considered as an empty value in template?). 

  • Profile Image
    Kevin_G
    Answered on January 27, 2020 at 06:29 PM

    I will escalate this issue to our back-end team in order to have this further checked as I cannot replicate the issue on a testing form, but I can replicate it on a cloned form of yours. 

    We will keep you updated via this thread. 

  • Profile Image
    murcielago
    Answered on February 04, 2020 at 09:56 AM

    Hi. For back-end team's info, I have solved this by re-creating a new version of notification email (I had tried this before but hadn't seemed to work. Now it did). 

  • Profile Image
    murcielago
    Answered on February 13, 2020 at 09:15 AM

    Edit: issue is not solved. spinners are stil being hidden when default value (zero) is left by user. 

  • Profile Image
    Welvin
    Answered on February 13, 2020 at 11:37 AM

    Thank you for the update, and our apologies for the continuous issue.

    The ticket is still assigned, and no update about it so far. If there is an update, the assigned team will let us know here. 

    Thank you for your patience and understanding on this matter. 

  • Profile Image
    murcielago
    Answered on February 17, 2020 at 10:25 AM

    Hi I have done further testing of Jotform and have found the reason of the malfunction of the autorespnder email in relation to the spinner with the value 0 as default.

    To replicate the unsolved problem in my form, I created a new form with just two elements: 1) a text question and 2) a spinner which is left with the default value of 0 (which is not an empty field).  

     

    1582120360Selection_024.jpg

    I have done simple experiment with template removing the text field row {typeA}:

    1581951004Selection_022.jpg

     

    Here are the results:

     

    scenario 1: If the email template is kept untouched, the 0 result is reported correctly in the email

    scenario 2: If I delete the text question row {typeA} in the email template, if the spinner  value is 0 (which is a valid number, NOT an empty field), the result disappears from the email. This is a BUG with Jotform. 

    scenario 3: With the  text question row {typeA} deleted, if I chose a different value than 0 in the spinner (i.e. 1), then the spinner result is reported correctly in email.  

     

    see emails below:

    1581950111Selection_020.jpg

     

    So this is the error:  removing a row from the email template makes the template mistakenly interpret the value 0 in the spinner as an empty field so it isn't reported in email output. 



    Now that the testing is complete [you are welcome], can you please solve this ASAP? 

     

    Thanks! 

     

  • Profile Image
    DawoodMD
    Answered on February 17, 2020 at 11:54 AM

    Hello murcielago,

    Thank you so much for the detailed info!

    I will immediately pass on the test report to our team. We will get back to you on this thread.