Card Form > Edit Thank You Page: will not redirect to the external link upon submission.

  • Profile Image
    nynoah0
    Asked on January 29, 2020 at 02:03 PM

    At the tend of my template it gives me a choice to say thank you for completing my form or to launch back to another web page. I have specified to launch to another webpage and I have clicked to do that but Jotform will not do that.  It also sometimes shows the sign up for Jotform advertisement on the bottom.  How can I fix this?

     

    Noah

     

    Screenshot
  • Profile Image
    BDAVID
    Answered on January 29, 2020 at 05:44 PM

    Thank you for contacting us. It will not always redirect to that page after submission, because of the conditions you have created to display a custom Thank You page:

    1580337841conditions_001.png

    So, you need to delete those conditions if you want to always redirect to that page. Let us know if you need more help.

  • Profile Image
    nynoah0
    Answered on January 29, 2020 at 09:08 PM

    My conditions don't have anything to do with this not launching to my scheduler page.  I can go all the way through the form answering it correctly and it just goes to the thank you page instead of redirect.

  • Profile Image
    BDAVID
    Answered on January 29, 2020 at 10:25 PM

    Hi again, you are right, it shows the default Thank You page. I have cloned your form, and disabled your conditions, and cleared forms cache, but the same Thank You page is shown up.

    Let me report this to our back-end team, you will be notified here when the issue gets fixed.

  • Profile Image
    nynoah0
    Answered on February 01, 2020 at 03:34 PM

    Still not fixed

  • Profile Image
    BDAVID
    Answered on February 01, 2020 at 08:16 PM

    This bug report is still opened. Unfortunately, there is no estimated time-frame for a resolution. We will notify you if we get any updates.

  • Profile Image
    BDAVID
    Answered on March 27, 2020 at 11:38 AM

    Good day @nynoah0, it seems like the issue has been fixed now. The form is redirecting to the external page. Could you please confirm if it works on your end?