Client's being unable to enter credit card details

  • Profile Image
    nattybats
    Asked on February 03, 2020 at 03:18 PM

    Hi there

    I'm continuing to have random issues with clients having their credit card details declined and then having to redo the entire form.  It is not every client for example I had one this past week go through without an issue and another that after several days of trying did not.

    This is an ongoing issue and while I understand that random difficulties are often almost impossible to trace, it's getting frustrating for myself and my clients.


    Any help would be appreciated

    I don't have a screen shot but this is an email from a client the other day:



    Unfortunately, I receive a Payment Error on submission of the form.  The error says:
     
    "Payment was unsuccessful. Your credit card was not charged.

     
    I have filled out the form 5 times now and keep getting this error.  It takes me back to filling out our contact numbers for both parents after we have added the numbers before moving to the credit card payment details, which we have entered previously and signed but the details are removed by the error.
     
  • Profile Image
    jherwin
    Answered on February 03, 2020 at 08:05 PM

    Can you please let us know to which form this issue is related to?

    Guide: Where-to-Find-My-Form-URL

    Also, I would suggest enabling the "Allow Browser AutoComplete" option in your form settings so that the form loads the data entered by users when they fail to make a transaction.
    1580778328allow browser.png
    Looking forward to your response.

  • Profile Image
    nattybats
    Answered on February 04, 2020 at 11:37 PM

    Thanks for your response

    So far there's been two forms that clients have reported the error:

    https://form.jotform.co/81008471777865

    and

    https://form.jotform.co/nattybats/assessments

    I've ensured that they both have the autocomplete set to yes.


    Many thanks


    Nat




  • Profile Image
    jherwin
    Answered on February 05, 2020 at 12:56 AM

    I don't see any problem with this form: (https://form.jotform.co/nattybats/assessments) but for this one (https://form.jotform.co/81008471777865), the product is not showing, please see my screenshot below.
    1580881930no products.png
    Please try to remove or add a new product and see if it will show or not.

    Also, if possible, ask the user to send a screenshot of the error presented at their end so that you can forward it to us. This will help us trace of what caused the error.