Form with disabled encryption still supplying encrypted submissions

  • Profile Image
    Connie 
    Asked on February 08, 2020 at 12:49 PM

    Good afternoon. I changed my form to be encrypted, and then realized that was not going to work for all the things I needed to do with the submissions.  I received 1 encrypted response, and the key made the information usable.  However, I turned off the encryption and then received a 2nd submission.  It is encrypted, and I can't seem to get to the information.  I didn't create another encryption key and didn't delete the one I initially downloaded.  Could you please help me be certain the encryption is turned off and the submissions will come in normally again?

    Here is a link to my form: https://form.jotform.com/200355115642142

    As you can see, it still has https at the beginning of the link, which might be part of the problem? It will not allow me to edit that part.

     

    Thank you for your time and assistance,

    Connie Light

  • Profile Image
    Jed_C
    Answered on February 08, 2020 at 05:40 PM

    I checked your form and I can confirm that encryption is already turned off. Also, I can see that new submissions are no longer encrypted and there were only two submissions that needs to be decrypted.

    Try clearing your browser cache and try logging in again then load your private key as see if that decrypts two of your encrypted submissions.

    As for the HTTPS, jotform is now using it as default URL even encryption is turned off. While a secure HTTPS form encrypts data in transfer, an encrypted form encrypts the stored data on top of that.

    Let us know how it goes.