What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Why don't I receive submissions by email?

    Asked by joshuaspest on April 13, 2011 at 05:22 PM

    I attempted to follow the steps outlined in the FAQ. Also attempted using different e-mails... and "If nothing helps send us an email. Make sure to include the URL of your form. We will debug the problem for you and send you the email server logs so that you can contact your hosting provider with the email tracking ID and ask them to find out what happens to the email."

    http://joshuaspest.com/contact+us.html?x=49&y=13

  • Profile Image

    Answered by onebreathcpr on April 13, 2011 at 05:29 PM

    I'm not receiving notifications either.

  • Profile Image

    Answered by allanftd on April 13, 2011 at 07:03 PM

    Hi joshuapest and onebreathcpr,

    Thanks for bringing this to our attention. We're eager to help both of you. 

    A possible reason for not receiving emails might be your spam filter or junk folder settings. Please check your spam/junk folder for JotForm's email notofocations. If it is there, make sure to set it as "No Spam" so that this would not be flagged as spam in the future. You may also find this link helpful: http://www.jotform.com/faq/#7 

    @onebreathcpr,

    Since you're using an email address with your own domain, it may also help at this point to contact your ISP or systems administrator regarding this issue so that they can also start investigating on their end. They may need to add jotform.com in their white list so that it will not be flagged as spam by the mail server.

    If the issue still persists, please let us know so that we can investigate further.  Thank you for using JotForm!

    JOTFORM SUPPORT

  • Profile Image

    Answered by lnclimited on April 13, 2011 at 07:26 PM

    I'm using Google Apps and my DNS is properly configured.  I checked SPAM folder and its not there.  Also, I get the Test emails just fine.  It's just when I go to the actual form and fill it out.  I don't get the email notification.  It's getting frustrating.  I logged into another another account (which I know works) and duplicated the form and still not receiving notifications.

  • Profile Image

    Answered by lnclimited on April 13, 2011 at 07:28 PM

    ******Sorry I meant to post the previous comment under the account that's not working for me******

    This is onebreathcpr:

    I'm using Google Apps and my DNS is properly configured.  I checked SPAM folder and its not there.  Also, I get the Test emails just fine.  It's just when I go to the actual form and fill it out.  I don't get the email notification.  It's getting frustrating.  I logged into another another account (which I know works) and duplicated the form and still not receiving notifications.

  • Profile Image
    JotForm Support

    Answered by NeilVicente on April 14, 2011 at 07:30 AM

    @lnclimited

    I checked our mail server logs for emails sent to the address info@onebreathcpr.com and I got the following messages:

    Current Server: Apr 14 01:24:44 ying sm-mta[22557]: p3E1wInO032534: to=<info@onebreathcpr.com>, delay=03:26:23, xdelay=00:00:00, mailer=esmtp, pri=1740630, relay=onebreathcpr.com., dsn=4.0.0, stat=Deferred: Name server: onebreathcpr.com.: host name lookup failure Apr 14 01:27:02 ying sm-mta[20543]: p3E1wInO032534: to=<info@onebreathcpr.com>, delay=03:28:41, xdelay=00:00:00, mailer=esmtp, pri=1830630, relay=onebreathcpr.com., dsn=4.0.0, stat=Deferred: Name server: onebreathcpr.com.: host name lookup failure Apr 14 01:47:03 ying sm-mta[24925]: p3E1wInO032534: to=<info@onebreathcpr.com>, delay=03:48:42, xdelay=00:00:00, mailer=esmtp, pri=1920630, relay=onebreathcpr.com., dsn=4.0.0, stat=Deferred: Name server: onebreathcpr.com.: host name lookup failure Apr 14 01:57:03 ying sm-mta[27096]: p3E1wInO032534: to=<info@onebreathcpr.com>, delay=03:58:42, xdelay=00:00:00, mailer=esmtp, pri=2010630, relay=onebreathcpr.com., dsn=4.0.0, stat=Deferred: Name server: onebreathcpr.com.: host name lookup failure Apr 14 07:23:22 ying sendmail[11679]: p3EBN200011679: to=info@onebreathcpr.com, delay=00:00:20, mailer=esmtp, pri=32663, dsn=4.4.3, stat=queued

    It looks like there is a problem with your dns configuration. Additionally, I have sent an email to that particular email address using my own email. Can you check your inbox if you received those emails?

    Also, can you try sending a message to that address using a different one (any email that is not hosted at @onebreathcpr.com )

    I'll await your feedback.

  • Profile Image

    Answered by onebreathcpr on April 14, 2011 at 11:15 AM

    Hi Neil.  I received one email from you at 7:18am EST.  I have sent/received email from different domains and deliveries are successful.

  • Profile Image
    JotForm Support

    Answered by NeilVicente on April 14, 2011 at 03:26 PM

    Ok, I now see stat=queued in our mail server logs for your email addresses wfletcher@onebreathcpr.com and info@onebreathcpr.com

    The test submission I have made earlier also did not go through,

    Apr 14 07:23:22 ying sendmail[11679]: p3EBN200011679: to=info@onebreathcpr.com, delay=00:00:20, mailer=esmtp, pri=32663, dsn=4.4.3, stat=queued

    It's a little weird that it shows stat=queued instead of 

    stat=Deferred: Name server: onebreathcpr.com.: host name lookup failure

    Did you just have this domain registered? If yes, then this might be caused by a delay in the propagation of your domain's DNS info, thus resulting to emails sent by our mail server not finding its way to the mail server associated with your domain.

    If that is the case, then we might just have to wait for up to 24 hrs and then do test submissions again and see how things turn out.

  • Profile Image

    Answered by onebreathcpr on April 15, 2011 at 12:46 AM

    domain was registered on 3/12/11.

  • Profile Image

    Answered by onebreathcpr on April 16, 2011 at 12:38 AM

    The form was  working yesterday.  Now it's not working again.  This is weird and frustrating at the same time.  I really don't want to switch to another form builder but I'm going to have to until this gets resolved.  I'm seeing more threads about this same problem.  I thought I was alone but apparently not.

  • Profile Image

    Answered by onebreathcpr on April 16, 2011 at 01:00 AM

    Found a workaround by adding an auto-responder and hidden box. Works good!