Media queries not working on our form

  • Profile Image
    DentalWebsiteBuilders
    Asked on February 28, 2020 at 07:40 AM

    Hi,


    I have used the form designer to inject custom css, but it is selectively applying the media query I used. The rest of my css is being applied in all scenarios, just not the media query part. It appears to be working if I "preview form", and it also works if I place the source code on my website. However, it does not work if I used the embed or iframe options.


    The conflict arises when I submit the form. For the embed and iframe options (not accepting the media query css), the form will display a thank you message directly in the page, which is the desired outcome. For the source code option (accepts the media query css), it redirects the entire page to an external thank you page.


    Any advice is appreciated.

  • Profile Image
    Kiran
    Answered on February 28, 2020 at 10:56 AM

    Are you referring to the form 'HornfeckDDS Contact Form' in your account? As I check the form, there doesn't seem to be any media queries added to the CSS code. Could you point us to the code and the form that you are referring so that we can check further to assist you?

    We will wait for your response. Thank you! 

  • Profile Image
    DentalWebsiteBuilders
    Answered on February 28, 2020 at 12:21 PM

    Hello,


    Yes, apologies, I had removed it since it wasn't working. In continued testing I found it to be the padding on a holder element that was throwing it off.


    Thanks. 

  • Profile Image
    Kiran
    Answered on February 28, 2020 at 01:29 PM

    No problem. We assume that the issue is now resolved for you. Please do not hesitate to get back to us if you need any further assistance. We will be happy to help. 

    Thank you for using Jotform!