What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Problems with creating a custom url

    Asked by erikastimac on May 17, 2013 at 07:58 PM

     

    Alright, I made a new test form and the secure url it is generating is: 

    https://secure.jotform.us/form/31367885236160

    So I have no idea why my first form was creating a url with words and not an ID number.

    That said, I'm still not understanding how the custom url should work. When I try to type in that field, I see the ID part of the Jotform url change to my username (and it has nothing to do with what I'm typing), and I cannot seem to create a custom url that will resolve.

    What syntax should the custom url have?

     

    ___________________________________

     

    Hi again,

    The name of my form is:  Bosque Del Apache 2014 Reservation Form
    The title of my html is: Bosque-2014-registration 

    The direct url that Jotform is generating is: http://www.jotform.us/erikastimac/davidstimac.com/Bosque-2014-registr (yes, it is cutting off the end)

    I have tried all of these urls:
    http://www.jotform.us/erikastimac/davidstimac.com/Bosque-2014-registr
    http://www.jotform.us/erikastimac/davidstimac.com/Bosque-2014-registration (I added the rest of the word thinking that the browser was cutting it off)
    Chrome won't let me move a cursor around the url in the generator box, but I can do so with Firefox. I thought perhaps I was not including the entire url in my cut/paste. Regardless, it does not work.
    I've also tried making this secure, as well as creating a custom url; both take me to a 404.  That may be an entirely different problem, so my first issue of course is to make this basic thing work and will cross those bridges later.
    What could be the problem here?
    Thanks!
    JotForm reservation form custom url problem name
  • Profile Image

    Answered by yselboller on May 17, 2013 at 08:23 PM

    Hello erikastimac,

    Kindly check this reference if you have followed the proper walk-through.

    http://www.jotform.com/help/144-How-to-use-Custom-Domains-with-Jotform

    If problem persists after doing what is in the instruction, feel free to let us know so that we could further help you.

    Kind Regards,

    Ysel

  • Profile Image
    JotForm Support

    Answered by jonathan on May 17, 2013 at 10:19 PM

    @ erikastimac

    Hi, in addition to Ysel's , you can create the custom URL link to your form like this

    (follow the numbered steps on the guide to access the custom URL button) 

     

    From your message description, it could be the issue was a too long custom URL?

    Have you tried testing with a lesser text URL? it should work.

    Please update us.

    Thanks.