Form randomly changing quantity number in the order

  • Profile Image
    mtmccray
    Asked on March 10, 2020 at 09:19 AM

    I've had 3 people report that the form is changing their order from 10 to 23 once they finalize their order. Unfortunately, I don't have a really good way to test this. Is this something that could happen?

    Why wouldn't it happen every time it's ordered?

  • Profile Image
    BJoanna
    Answered on March 10, 2020 at 11:26 AM

    Can you please tell us to exactly which product of the payment field is your issue related to? 

    I filled your form but I was not able to replicate the issue. I cannot submit it because it is in Live mode. 

    You can also fill the form or make a test submission to see if you can replicate the issue. 

  • Profile Image
    mtmccray
    Answered on March 10, 2020 at 11:42 AM

    Some people are saying when they order the products in this screenshot (see attached) that before they hit submit. It will say the correct amount for 10 leads. After hitting submit they are saying the form changes the order to 23 leads and charges them for that.

    How do I change it back to test mode for testing purposes? Or to troubleshoot?

    1583854931screenshot-finalexpensesalesle

  • Profile Image
    BJoanna
    Answered on March 10, 2020 at 01:08 PM

    When I tested your form, the numbers I selected did not change when I tried to submit the form. The form was not submitted because I used a test credit card. 

    I'm also unable to replicate the issue on my cloned form in Test Mode when I submit it. 

    Here is my cloned form - https://form.jotform.com/200694913957971

    Feel free to test it. 

  • Profile Image
    mtmccray
    Answered on March 10, 2020 at 03:14 PM

    Okay, I'm having my team test the form. However, we can't check it because it's not our form if it has changed the order to 23, instead of 10. You'll have to let me know.

  • Profile Image
    Kevin_G
    Answered on March 10, 2020 at 06:49 PM

    I've just reviewed your form and it seems to have worked as expected. Please let us know once you've performed the tests and the name used so we can check this. 

    Also, if possible share us some screenshots about the issue, note that attached images via email replies will not reach this thread, but you can upload your images following this guide: How to Post Screenshots to Our Support Forum 

    Looking forward to your response. 

  • Profile Image
    mtmccray
    Answered on March 11, 2020 at 09:27 AM

    We were unable to replicate the issue. What we have done to combat the "mistakes" is added more required fields, and require a review your order button before the user can submit it. I think this just comes down to user error.

  • Profile Image
    Kiran
    Answered on March 11, 2020 at 10:55 AM

    Great. You may also add the Get User agent widget to the form to capture the browser information that might help in case of any further issue.

    https://www.jotform.com/help/234-How-to-Catch-User-s-Browser-Info

    Please get back to us if you need any further assistance. We will be happy to help.