Authorize.net form goes to a blank page and nothing happens

  • Profile Image
    SFB2020
    Asked on March 11, 2020 at 12:58 PM

    Once the credit card is successfully inputted it goes to a blank page and nothing happens. No confirmation and no payment charge. 


  • Profile Image
    Welvin
    Answered on March 11, 2020 at 03:06 PM

    Authorize.net seems to have worked upon testing. 

    I have re-saved your form and cleared the forms cache. Kindly do some tests again and let us know if the issue persists. 

  • Profile Image
    SFB2020
    Answered on March 11, 2020 at 03:23 PM

    Hello Welvin,

    I am not getting this message: 1583954620jotform2.png

     
  • Profile Image
    Welvin
    Answered on March 11, 2020 at 04:50 PM

    All I get was AVS mismatch error. I got charged somehow, can you check that? I tried with my two cards. 

    Anyways, if you have a different card, please try it and let us know if the issue persists. The error is too generic, and usually, it is a credential problem. However, considering that I was able to submit it, I don't that is it. 

  • Profile Image
    SFB2020
    Answered on March 11, 2020 at 04:52 PM

    Does jotform accept american express? That may be the issue.

  • Profile Image
    Welvin
    Answered on March 11, 2020 at 06:20 PM

    We integrate with Authorize.net, and we used their API. That means we are dependent on the services and functions they offer. As far as I know, they support American Express, but you will need to enable that or contact your provider first.

    Here are guides from Authorize.net you can check and follow:

    https://support.authorize.net/s/article/How-can-I-add-remove-credit-card-types-that-I-can-accept

    https://support.authorize.net/s/article/American-Express-Card-Code-Verification

    You may also consider contacting Authorize.net directly to discuss this matter.