Pipedrive fields are marked as required in the Integration even though they are not

  • Profile Image
    Scott Leizman
    Asked on March 25, 2020 at 08:54 PM

    The fields are all marked as “required” and won’t allow null values even though the important fields are turned off in Pipedrive.



    This is a re-post of a comment on How to integrate JotForm with Pipedrive

  • Profile Image
    gerardw
    Answered on March 26, 2020 at 12:00 AM

    Could you let us know on which form you are facing an issue with Pipedrive? I checked your last edited form and also both forms in your account. None of them have integration with Pipedrive. Also, both forms in your account have all fields marked as not required.

    Additionally, please explain your issue so that we could try to replicate it from our end too.

  • Profile Image
    leizman
    Answered on March 26, 2020 at 12:29 AM
    Again. This is an extremely inefficient way to troubleshoot a problem!!
    Scott Leizman
    ...
  • Profile Image
    leizman
    Answered on March 26, 2020 at 12:29 AM
    It’s the Information Request Form. And like I said, all of the fields except for the first 1 or 2 are set to “required”. I’m sorry that you don’t believe me. I have no reason to make this up.
    Scott Leizman
    ...
  • Profile Image
    gerardw
    Answered on March 26, 2020 at 01:56 AM

    Hello Scott, 

    Apologies if there was any confusion created and thank you for providing the form information.

    I had checked this form earlier too. I can see that you have provided asterisks for the fields. Sorry, but that is not how a required function works. You will have to mark a field as required from the fields' properties. Please check the screen cast below on how that is to be done:

    1585202053screencast26032020_1.gif

    Here is a related guide for reference: https://www.jotform.com/help/546-How-to-Set-a-Field-as-Required-or-Non-Required 

    Do mark them as required and then test the Pipedrive integration.

  • Profile Image
    leizman
    Answered on March 26, 2020 at 02:29 AM
    You are still not understanding the issue. The issue is with the Pipedrive fields all being marked as required in the integration tool when they are not marked as important in Pipedrive.
    Scott Leizman
    ...
  • Profile Image
    leizman
    Answered on March 26, 2020 at 02:29 AM
    Did you receive the screenshots? Again, this is a ridiculous way to resolve a technical issue over email!
    Scott Leizman
    ...
  • Profile Image
    Richie_P
    Answered on March 26, 2020 at 04:53 AM

    To clarify, do you want to create an "Add a deal" Pipedrive action?

    Currently, it is not possible to remove the Deal Title or the Name field or the first field default which is a required field when you match the fields in Pipedrive.

    However, you may remove/replace the 2nd field when mapping by clicking on the x mark when you hover over.

    Screen cast:

    You may view the thread created at this link:https://www.jotform.com/answers/2226192

    Hope this information helps.

    If you have further questions, let us know.

  • Profile Image
    leizman
    Answered on March 26, 2020 at 09:29 AM
    Are you kidding me? Didn’t you see the screenshots I sent. ALL OF THE FILED HAVE “REQUIRED”, TO THE RIGHT OF THE FIELD. THERE IS NO WAY TO REMOVE ANY OF THE FIELDS. There are about 15 fields and they all say “required”. They cannot be removed. There is no X next to them to remove them. Do you understand what I am telling you? Are you even reading my emails?
    Scott Leizman
    ...
  • Profile Image
    Welvin
    Answered on March 26, 2020 at 11:16 AM

    Our apologies, but our support forum does not support email attachments yet, inline or attached files. You will have to do the following:

    1. Access this thread, link here: https://www.jotform.com/answers/2226192.

    2. Click the Image icon on this thread to upload screenshots.


    As for the other support channel, we only have this forum, email, and chat. But our chat is currently offline due to the volume of forum requests we get. As much as we want to call you, it is not an option this time.

    Anyways, I do understand the problem. I tried this, but there seems to be a problem with my Pipedrive account. I checked earlier, and I was able to pull some of the fields. It is no longer doing that likely because my account has expired.

    Is there a way you can share with us your login with Pipedrive? If you need it to be private, you can send it to me at welvin@jotform.com. Otherwise, send that to support@jotform.com and put thread ID#2226192 in the subject line of your email as your reference. We'd be happy to troubleshoot this for you directly instead of us suggesting what to do. 

    If sharing your login is not an option, try disconnecting JotForm from your Pipedrive's app list (https://support.pipedrive.com/hc/en-us/articles/360002279278-App-Panels). You'll be asked again to connect through our Form Builder, please do that to see if the problem persists. 

    Thank you and I hope that helps.