What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Saving form for later doesn't work

    Asked by ffmwoc on June 04, 2013 at 02:06 PM

    I'm trying to design a form that has multiple pages to go back and resume at anytime.  It seems that the 1st and 2nd page is getting saved but from the 3rd thereafter is not being saved.  Also, when I click submit I get an error saying that multiple submissions are not allowed and I have 0 submissions for the form.

    Form to register 1st:  http://form.jotform.us/form/31488635228158

    Form to fill out that is having save issues: http://form.jotform.us/form/31311388917153

    The first form will send an email with the ?session=<emailaddress> added to the URL. 

    Please advise.

     

     

     

    Page URL:
    http://form.jotform.us/form/31311388917153

    saving form doesn't work Submissions JotForm email session
  • Profile Image
    JotForm Support

    Answered by jonathan on June 04, 2013 at 04:03 PM

    Hi,

    From what I have checked so far, you have setup email session on the main form, yet the unique question limit for email field is also set

     

    As far as I understand, every user of your form can only use the 1st form when the email is provided, then, when they go to the 2nd form (having the same email) -- the 2nd form will be able to recognized already the existence of the email (from first form), this is the reason the 2nd form will always fail.

    I suggest you removed the unique question  setting on the email field. And test again.

    You can also create Save Forms and Continue Later using this guide

    How-to-Enable-Auto-Fill-Feature-Save-Form-Entries-to-Continue-Later

    Hope this help. Please inform us if you have further concern.

    Thanks.

  • Profile Image

    Answered by ffmwoc on June 04, 2013 at 04:58 PM

    it seems like after enabling the auto-fill that the save is not working from the 3rd page and thereafter...

     

    http://form.jotform.us/form/31311388917153?session=shebu.mathew@gmail.com

  • Profile Image
    JotForm Support

    Answered by jonathan on June 04, 2013 at 07:44 PM

    Hi, 

    I used your provided link to the session form 

    http://form.jotform.us/form/31311388917153?session=shebu.mathew@gmail.com 

    and I have progressed already up the "Healthth" page which is pag 8 I think...

    I am saying.., it seems to be working just fine when I tested.

    Can you please check again, try clearing your browser's cache. See if it help.

    Please inform us if the issue persists.

    Thanks.

  • Profile Image

    Answered by ffmwoc on June 04, 2013 at 10:44 PM

    I've cleared the browser's cache but I still notice that the values third page  that you entered are no longer there.  I even tried filling them out and closed the browser and the fields from page 3 onward are all empty.

  • Profile Image
    JotForm Support

    Answered by Welvin on June 05, 2013 at 12:52 AM

    Hi,

    I've check every settings in your form and found out that the Unique Question Settings is causing the issue to happen. As suggested by my colleague on his previous response, you may consider removing Unique Question from the Email field into your form which is located on the second page.

    I've cloned your form and made the changes and everything works perfectly thereafter: http://www.jotformpro.com/form/31551133180947?session=vincecudas@gmail.com

     

    Thanks

  • Profile Image

    Answered by ffmwoc on June 05, 2013 at 10:04 AM
    that worked perfectly. thanks!
  • Profile Image

    Answered by sidharth_kch on June 05, 2013 at 11:10 AM

    @ffmwoc

    Glad to know that your issue was resolved.

    Should you have any questions feel free to contact us.

    Thanks,

    Sidharth