What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Unique Question is not working with form ?session

    Asked by HRCfamily on June 07, 2013 at 11:56 AM

    Hi-

    I am having a problem with a form consistently giving a "muliple form submission error" when I have limited the form to have unique email ID submission, but the form gives the error even when the email entered has not previously been submitted. Here is the form: http://form.jotform.us/form/31476614846158

     

    I am wondering if this is due to the fact that this survey is linked to an original survey by the submitted email. Here is the link to the original survey: http://form.jotformpro.com/form/31547658719972. Once this survey is completed it gives you a unique link to the next survey indicated above. However, no matter what email address I used, I continually recieved the "multiple submissions" error at the end of the survey. Help?

     

    Thanks!

     

    -HRC family

    Page URL:
    http://form.jotform.us/form/31476614846158

    unique question save and continue
  • Profile Image
    JotForm Support

    Answered by KadeJM on June 07, 2013 at 12:50 PM

    So you are getting an Error on the second form with Multiple Submissions if I am understanding your problem right. 

    I've started looking into your issue but so far I am a bit confused at the moment so I would like to know are you speaking of the Warning Message telling you that Multiple Submissions are not allowed? I take it this is the One you mentioned as shown in the picture below? 

    Do you mind if I test this some more via your form itself so that I can check this issue more accurately?

  • Profile Image

    Answered by HRCfamily on June 07, 2013 at 01:31 PM

    No, it's actually not the warning message, it's a full page that says "sorry, mutiple submissions are not allowed" and displays after I hit submit on the final page on the survey. Go for it on testing the form! Sorry if this is confusing.

     

    Thanks!

  • Profile Image

    Answered by sidharth_kch on June 07, 2013 at 02:52 PM

    @HRCfamily

    I checked your form and see that you have set the "Your E-Mail" field as "Unique Question" on your form.

    I was able to successfully do test submissions and got the error only when I entered the same email id twice.

    Request you to please clear your submission list and test your form once again. Let us know the outcome.

    Thanks,

    Sidharth

  • Profile Image

    Answered by HRCfamily on June 07, 2013 at 04:27 PM

    Hi Sidarth,

    I tried doing that but we are still experiencing the same problem. We are very confused!

     

    Thanks,

    Rachel

  • Profile Image
    JotForm Support

    Answered by Mike_T on June 07, 2013 at 05:22 PM

    I was able to reproduce that problem. Unfortunately, the Unique Question validation is not working right during the "save and continue later session".

    I have escalated this problem to our Developers, and we will get back to you as soon as we have any updates.

    In the meantime, you may consider using our moder "save and continue later" option:

    How to Enable Auto Fill Feature | Save Form Entries to Continue Later

    Note, it is working without any session links, but it is not saving the files and working on the same browser only.

  • Profile Image
    JotForm Support

    Answered by Mike_T on June 23, 2013 at 01:57 AM

    Hello Rachel.  We've now managed to find out the problem and made a fix.  Your form should be working fine now using sessions.

    If you continue to experience problems with your forms, please do let us know.

    Thanks.