Response to radio buttons is not showing up on submission email

  • Profile Image
    jbursky
    Asked on June 09, 2013 at 12:56 PM

    Hi,

     

    I love JotForm; however, I am having a problem with all of my radio buttons that have the following conditions:

    1. There are only two possible responses. AND

    2. The two responses are the same for the the three radio buttons in question: "Yes" or "No"

    It doesn't matter if these are required fields or not.

    All other radio buttons are functioning properly.

    Thanks in advance for your help.

    Regards,

    Jay

  • Profile Image
    EliezerN
    Answered on June 09, 2013 at 02:13 PM

    Hello, 

    I have cloned your form and made som settings, I have found a solution for this issue.

    The issue was that the data of the three radio button questions was not appearing, right?, so I just looked for the Field IDs and inserted them in the Email notification body. You can learn more about How to Find Field IDs & Names in this link.

    To do that Please follow the instructions bellow:

    - click on the field, then click on the properties icon, then choose Properties Option. In the next window you will fine=d the Id and the name of the field.

     

    You'll have to take that Id to insert it into the Email Notification Body.

    To Insert it into the Notification Body do the next:

    - Go to Setup and embed tab the to Email Alerts. There choose notification.

     

    Then insert the text that is highlighted in the screenshot.

     

    Finally click on Finish, save your form and test it.

    The notification will look this way>

     

    I hope this helps. It's a pleasure to assist you.

    Thanks!

  • Profile Image
    EliezerN
    Answered on June 09, 2013 at 02:16 PM

    Also you can cloned my form with the changes to check them: http://support.jotform.com/form/31595623278967

  • Profile Image
    jbursky
    Answered on June 09, 2013 at 04:59 PM

    Eliezer,

    Thanks for getting back to me.  I haven't had the chance to make the changes yet; however, I have a similar problem with my Contact Message form.  Specifically, the text area "Your Message" is not appearing in the submission email.  I used your instructions above; however, there is no properties option that I can see nor anything similar to Field Details.

    Thanks in advance once again for your help.

    Regards,

    Jay

  • Profile Image
    jonathan
    Answered on June 09, 2013 at 05:30 PM

    @Jay

    Hi, if you have amended the notification email template and then updated the form afterwards(change, add,edit fields),  there is a chance that the new amended fields in your form will not reflect the changes on the form's notification email template.

    To resolve this conflict, create a new notification email using the Add New Email button. This will ensure that, the notificaiton template will have all the fields included of the updated/modified form.

     

     

    Hope this help. Please inform us if you have further question.

    Thanks.