Square Integration Test Mode: INVALID_REQUEST_ERROR Error when submitting the Form.

  • Profile Image
    hrkimmie
    Asked on April 29, 2020 at 08:57 PM

    I keep getting an error message no matter what i input in my form to collect square payments.  I have the test environment on and i have used all the numbers.  I get error messages double submissions aren't allowed and some other random error message.  I've spent too much time trying to figure this out and i have clients that need to pay.  but i obviously cant give them the link if i don't know how it works myself.  Please help.

  • Profile Image
    VincentJay
    Answered on April 29, 2020 at 09:18 PM

    Hi,

    Could you please provide the error message so we can check it further? Please share the screenshot here in the Support Ticket by following this guide: 

    https://www.jotform.com/help/438-How-to-Post-Screenshots-to-Our-Support-Forum

    We'll wait for your response. Thank you.

  • Profile Image
    hrkimmie
    Answered on April 29, 2020 at 09:23 PM

    Also, when i put the encryption on, the form wont go past the first page.

  • Profile Image
    hrkimmie
    Answered on April 29, 2020 at 09:30 PM

    1588210204IMG_0360.jpg1588210216IMG_0359.jpg1588210227IMG_0358.jpg

  • Profile Image
    Jed_C
    Answered on April 29, 2020 at 09:33 PM

    Try enabling the test mode in your gateway settings and test your form again, see if that works.

    1588210393The Easiest Online Form Builde

  • Profile Image
    Jed_C
    Answered on April 29, 2020 at 09:58 PM

    Not sure why it's not working on your end. I just tried it with my test account and it works. Can you please test my cloned version here https://form.jotform.com/201198802769969.

    I have now forwarded this to our L2 team for further checking and we'll let you know once we have an update.

  • Profile Image
    Sonnyfer
    Answered on April 29, 2020 at 11:34 PM

    None of the test forms work.  I just tried your link and it still didn’t work.  I put the visa number in 411111111111111 and 111 ccv and it still gave me a system error.  

    Apologies for the inconvenience. I can see that the issue has already been escalated to our backend team for further checking. We will notify you via this ticket once we have an update.

    I cannot move past the first page of my form when it’s encrypted.  Why?  The form shows non secure when opened. 

    I have moved this query to a separate ticket to avoid confusion. Kindly follow this link and we'll be answering you there shortly.


  • Profile Image
    hrkimmie
    Answered on April 29, 2020 at 11:43 PM

    I had to run a LIVE test on myself because the system isn’t integrating at all.  There was no alert from square.  

    Also, there’s no way to manage the payments through square.  The only way a subscription can be canceled is through JotForm.  Also it’s not supposed to charge right away and it definitely did, despite the settings being charge later. 


    Also to add, there is no link in the email receipt from jotform for square.  Is that somewhere and I missed including that.  If so, can you please show me so I can find it and update it. It just seems like a lot is missing and I can’t use this for my customers if the payment system isn’t going to be correct.  Please advise.
     
  • Profile Image
    Vanessa_T
    Answered on April 30, 2020 at 12:23 AM

    The connection concern has already been forwarded to our backend team.

    As for the subscription issue, I have moved it to a separate ticket:

    https://www.jotform.com/answers/2293287

    For the email issue, will respond to you in here:

    https://www.jotform.com/answers/2293303

  • Profile Image
    ender
    Answered on August 04, 2020 at 10:55 AM

    Hello,

    We fixed the bug about Square's test mode. Would you please check and inform us if you have any problems?

    Thank you, best regards.