Some Hubspot fields are not populating

  • Profile Image
    MurraySeward
    Asked on May 08, 2020 at 02:42 PM

    I have the same issue as Damian - some of the fields aren't populating.



    This is a re-post of a comment on How to Integrate JotForm with Hubspot CRM

  • Profile Image
    JohnRex
    Answered on May 08, 2020 at 03:24 PM

    Hello @MurraySeward - if this the form you're working on: Self- & Virtually-Hosted Team Building Activity Order Form (CanadaRep)I can see that you were able to map all your form fields with HUBSPOT:

    15889657752311789.png

    Now, if some fields aren't from the form aren't populating in Hubspot, make sure that the custom fields created in Hubspot have the same field type as that of the form fields. If it's a date field in the form, it should be a date picker field as well in Hubspot.

    Could you please specify which of those fields above is not populating in your Hubspot CRM? We'll try to replicate that on our end. It would be helpful if you could also let us know the field type of that custom field that you set in Hubspot.

  • Profile Image
    MurraySeward
    Answered on May 08, 2020 at 07:06 PM

    Hi - I'm referring to the "CanadaRep" form. Here are the fields that aren't working and how they are set up in HubSpot:

    Event St/Province - Dropdown select field

    Objective - Dropdown select field

    Salesforce Product - Dropdown select field

    From Type - Single line text 

  • Profile Image
    JohnRex
    Answered on May 08, 2020 at 07:32 PM

    Thank you for providing these details.

    Let me have some more time to perform a few tests on my end by replicating the set up you created.

    I'll get back to you here once done.

  • Profile Image
    JohnRex
    Answered on May 09, 2020 at 08:38 AM

    Thank you for waiting!

    So here are my findings:

    Event St/Province - Dropdown select field

    I can see that you are using pre-defined options here. I suggest you add the options manually:

    15890269742311789 2.png

    Also, make sure that the options match the one you have in the field's properties in Hubspot:

    15890270712311789 3.png

    Objective - Dropdown select field 

    Salesforce Product - Dropdown select field

    These fields in your form are Short Entry Text fields while in Hubspot, you mentioned that these are DropDown fields. It should be of the same type. So I suggest replacing it with a DropDown field in the form.

    From Type - Single line text 

    This works on my end:

    15890278712311789 4.png