Secure form doesn't seem to be secure

  • Profile Image
    mikemahoney100
    Asked on April 25, 2011 at 05:31 PM

    I've read the FAQ's & looked in the forum, but the secure form option still does not seem to work. I put a secure form into a website (created with Xara). When I go onto the form in the website, there is no https in the address, and when I submit the form, the information comes directly to me in an email instead of being held on your server for me to retrieve. It just doesn't seem to function as a secure form in any manner. 

    I plan to use the forms on two different business websites, but I am using a test site for such things as this form. The test site address is below.

  • Profile Image
    mliz
    Answered on April 25, 2011 at 09:06 PM

    Hello,

    The ssl is only applied on the form it does not cover the domain where you
    embed the form. If you pull up the form itself via jotform address the ssl
    certificate is displayed and verified:

    https://www.jotform.com/form/11123858251



    If you wish to add ssl on your domain you will need to get in touch with your hosting
    company and ask them to have this added to your domain.


    An email notification was set up on the form this is why you receive data via email.
    You can remove this email notification and just have the submitted data on the
    server and access it by logging in to your account.

    To remove the notification email please do the following:

    1. Open the Form in JotForm
    2. Click on 'Setup and Embed'
    3. Choose 'Email Alerts' and select the notification
    4. From the Pop up box click on 'Delete Email' on the lower left hand corner.

    Thank you for using JotForm.

    Best Regards,
    Mliz

  • Profile Image
    mikemahoney100
    Answered on April 26, 2011 at 10:05 AM

    Got it. Thanks!