form works in IE but not in Firefox or Chrome or Safari

  • Profile Image
    missionsnetwork
    Asked on April 26, 2011 at 01:34 AM

    Works only in IE and no other browser, including Mac Safari.

    Have tried creating a different form.   Same results.

    Have tried a different form theme.  Same results

    Any help would be greatly appreciated.  Very frustrating because I've created many forms before and they all work great!  Why this?  Why now?  Just don't get it.

    www.missions-network.org/contact.htm

  • Profile Image
    missionsnetwork
    Answered on April 26, 2011 at 02:13 AM

    I found the problem was in my design software. I use Xara Web Designer 7 Premium.  

    Somehow the form was put on an incorrect layer, so I moved it to the correct layer of my site and problem was instantly resolved!

    Will definitely store this one in my head for future use...

  • Profile Image
    NeilVicente
    Answered on April 26, 2011 at 05:51 AM

    Hi,

    I apologize for not being able to respond to your question quickly, but at the same time I am glad that you were able to sort things out by yourself. If you have other queries, do not hesitate to ask us for assistance. Thank you for using Jotform.

    Regards,
    Neil

  • Profile Image
    missionsnetwork
    Answered on April 26, 2011 at 05:52 PM

    Now I find that everything is working for those on a PC but the MAC folks using Safari can't use the form at all.  Any ideas?

    Thanks,

    Curly

     

  • Profile Image
    liyam
    Answered on April 26, 2011 at 10:48 PM

    Hello Curly,

    Can you provide more details about your problem about MAC users' safari not being able to use your form?  Have you checked it in PC users' Safari browser if it's also the same case?

    I just noticed that when I used Safari to browse your page, it took a while to load the whole page.  Though I am a PC user.

    Thanks.