Form Conditions: Saving one particular condition on this user's form hangs up the system

  • Profile Image
    tsdosanjh
    Asked on May 16, 2020 at 09:50 AM

    Hi,

    I have a 2 similar jotforms called "secure lab order form" and "independents form 2"

    Both forms contain a field called data for QR code.

    This field is filled in using a condition

    I am trying to update that condition with the correct data fields but it doesn't let me save my work & page just becomes unresponsive.  Please see screenshot attached and let me know how to fix this issue.

    Tanjit

    Screenshot
  • Profile Image
    Patrick_R
    Answered on May 16, 2020 at 11:08 AM

    Hi! Let me look into this. I'll get back to you shortly with an update.

    Thank you!

  • Profile Image
    Patrick_R
    Answered on May 16, 2020 at 11:35 AM

    Hello Tanjit! I can replicate the issue at my end on a cloned version of your Form "Secure Lab Order Form". My browser hangs when I try to save this particular condition on a cloned version of your Form (even without making any changes to the condition). Following is the condition that is creating this problem:

    1589643914chrome-capture - 2020-05-16T21

    Infact, my computer also hung up and I had to hard-reboot my Computer. I tested this issue multiple times on a Linux (Ubuntu) Machine + Google Chrome.

    I also tried making a duplicate condition from scratch (by adding fields one-by-one and concatenating them with the comma ',' symbol). Again, when I pressed the "SAVE" button, my browser hung up. I think some sort of JS loop might be causing this problem.

    You have 97 conditions for this particular Form, I disabled all conditions and re-tried; it was of no use and the browser still hangs up.

    For this reason, I'll have to escalate this issue to the concerned department, so that they can have a look and solve the problem.

    We apologize for the inconvenience this might cause you.

  • Profile Image
    tsdosanjh
    Answered on May 18, 2020 at 02:38 PM

    Any progress on this?

  • Profile Image
    Patrick_R
    Answered on May 18, 2020 at 04:03 PM

    Hello Tanjit! The issue has been escalated to the concerned department and is being worked upon on priority basis. It won't be possible for us to provide you an ETA on this issue but I will forward your message to the concerned department.

    Our apologies for the inconvenience caused.

  • Profile Image
    tsdosanjh
    Answered on May 25, 2020 at 05:32 AM

    What I've noticed is if in the screenshot I try to change a "0-9"(black) to "A-Z" (light brown) it doesn't let me do that.  Surname is A-Z but some of the other fields are also A-Z characters.

    Another thing is as you see from screenshot my DO is Copy multiple field values.  But when I go into the condition again later on the DO goes back to Calculate a fields value.

    Any support you can give to fix would be great.


    1590398934Screen Shot 2020-05-25 at 10.2


  • Profile Image
    gerardw
    Answered on May 25, 2020 at 08:02 AM

    I am able to view this condition correctly on your form. I opened and checked your form multiple times, but the condition below remained the same.

    15904079372505_13.png

    As per the field format, only the Surname field is in a string format i.e. A-Z.

    The DO section is also shown correctly.

    I think it could have been a form cache issue at your end. I have anyway cleared the form caches on your account. Please check and let us know.

  • Profile Image
    tsdosanjh
    Answered on May 25, 2020 at 08:32 AM

    Hi Gerard,

    1. your screenshot shows the DO as Calculate a fields value.  When I set the condition up the DO was as a Copy multiple fields value.

    2.  as stated above, some of the fields contain letters but they are all 0-9.  When I try to set prisoner number as A-Z its not allowing me to do this (screenshot showing this attached).  In addition to prisoner number there are more fields which are letter fields but again its not allowing me to do that.

    Please can someone look into these issues properly as its been going on for over a week now.

    Thanks,

    Tanjit

    1590409717Screen Shot 2020-05-25 at 13.2


  • Profile Image
    Sonnyfer
    Answered on May 25, 2020 at 09:53 AM

    Hi Tanjit - Apologies for the inconvenience.

    I have cloned your form and was able to replicate the issue. I also have sent a follow up to our backend team to expedite the resolution of this issue. They will reach out to you the soonest.

    Thank you for understanding.