What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Why are the edit links via e-mail notification not working properly?

    Asked by truckersamerica on June 24, 2013 at 11:14 AM

    We have certain conditions set-up to send notification e-mail's to different people based on which selection is made on the form. These notification e-mail's are sent containing the PDF Download link as well as a link to edit the PDF within JotForm. We are now finding that, on multiple occasions, the edit link is simply loading a blank version of the form with none of the fields from the original application filled in (which are normally present since we are 'editing' it; after all). 

    The PDF's, on the other hand, download perfectly find and display all form data. Additionally, when I go to edit a form with a blank edit link within JotForm itself (not the link; actually in the forms submissions) it also displays blank form data and the original application data is missing (but I can still download the PDF just fine). 

    What's going on? 

    Page URL:
    https://submit.jotformpro.com/form.php?formID=30973952280964&amp;sid=2<br/>37652661461396725&amp;mode=edit

    Submissions JotForm edit link download link
  • Profile Image

    Answered by truckersamerica on June 24, 2013 at 12:04 PM

    Does anyone have a solution to this problem? 

  • Profile Image

    Answered by pinoytech on June 24, 2013 at 12:57 PM

    Hi,

    Sorry for the inconvenience that may have caused. With regards the issue of Edit link of your form, it seems to be working fine on my end upon checking. Please take a look at this video: http://www.screencast.com/t/YxsGtoYsH4lR

    Have you tried already clearing your browser cache and cookies? If not, can you please give a try if that fixed the issue or not.

    Thank you!