No message prompt after disable the Submit button using Card Form

  • Profile Image
    mdalif.zappiling
    Asked on May 22, 2020 at 01:23 AM

    I would like to check regarding the Enable/Require Field. I have already set conditional logic to one of the questions in the form using Enable/Require Field and expecting it will be prompt the message but it doesn't. I am not really sure whether it is the error.

  • Profile Image
    Kiran
    Answered on May 22, 2020 at 03:15 AM

    As I check your form, the conditions are set to disable the Submit button. So, the message shall be displayed when the form is displaying the Submit button i.e., at the end of the form. Also, since the form is enabled to Review before Submit button, the message seems to be displayed before the Preview message.

    159013165420200522_124358.png

    You may consider adding conditions to hide the fields that display after based on the options so that the message shall be displayed on the form. 

    Thanks!

  • Profile Image
    mdalif
    Answered on May 22, 2020 at 04:37 AM

    Hi Kiran,

    Appreciate your assistance on this matter. Actually the message didn't prompt at all even after I have disabled the review on the setting.

    I have attached the screenshots of the condition that I have set and after disabled the review. I may some mistakes somewhere which I can't find it.

    1590136383Untitled.png

    1590136415Untitled01.png

    Thanks!


  • Profile Image
    Richie_P
    Answered on May 22, 2020 at 06:57 AM

    I would suggest combining all your disable conditions into 1 rule of condition.

    Example:

    15901449183.png

    Do note that you would have to disabled the old conditions.


    Please give it a try and let us know if the issue still remains.

  • Profile Image
    mdalif
    Answered on May 22, 2020 at 09:14 AM

    Hi Richie,

    Thanks for the reply on the issue.

    I have already amended the conditions to "ANY" and "ALL" as suggested by it still doesn't work.

    1590152994Capture01.PNG 1590153042Capture02.PNG

    1590153217Capture03.PNG

    Thanks!

  • Profile Image
    Vanessa_T
    Answered on May 22, 2020 at 10:08 AM

    I checked your form and can see 3 conditions that disables the submit button.

    159015644400288.jpg

    Just to confirm, if I understand your goal correctly, if they have any possibility of having COVID-19, then user should not be able to submit.

    As such, kindly collate all the triggers that disables the submit button within one condition only.

    159015646300289.jpg

    I just tried it on my cloned form and was able to see the error message.

    159015648300290.jpg

  • Profile Image
    mdalif
    Answered on May 22, 2020 at 10:36 AM

    Hi Vanessa,

    Thanks for the reply and attend to the issue. I have already amended the form according to your suggestion and finally, it works. 

    I would like to check on another issue whether is there any way to set a condition to the value of body temperature of more than 37.5 and it will trigger the disable submit and prompt the message?


    Thanks!

  • Profile Image
    bawwad032
    Answered on May 22, 2020 at 11:12 AM

    Hi mdalif,


    You should be able to add a greater than or less than condition by using a number element for the body temperature field.

    1590159910number.PNG

    After changing to a number field you will be able to add a new rule in which you can compare to a certain value.

    1590159996body temp.PNG


    1590160300conditions.PNG






  • Profile Image
    Jimmy_D
    Answered on May 22, 2020 at 11:39 AM

    Hi,

    As @bawwad032 suggested, first, you need to replace the "What is your Body Temperature" text field by a number field, if you wish to use a greater than comparison on your conditions. Once the field has been replacing you can then update your condition. 

    I hope this was helpful. Let us know if you have more questions.

    Regards, 



  • Profile Image
    mdalif
    Answered on May 23, 2020 at 12:21 AM

    Hi bawwad032 and Jimmy_D,

    First of all, thanks for the guidance to help me to solve the issue for the message prompt. It works now. Now I understand the mistakes that I made during building the card form.


    I have another question related to another form that I created similar to the Card form but using the normal form.

    I would like to set the condition and prompt the same message as in the Card but I can't do it.  Here is the link to the form: https://form.jotform.com/201410129078446.

    What I did was I created another page to prompt the message but after submitting the form, the message on another page will be in the pdf form. As shown below:

    1590207593Capture04.PNG

    Thanks!

  • Profile Image
    Vanessa_T
    Answered on May 23, 2020 at 12:35 AM

    I have moved your last message to a separate ticket since it is of a different topic:

    https://www.jotform.com/answers/2342235