Payment Tools: Condition is not triggered when a product is checked by selecting its quantity

  • Profile Image
    usara
    Asked on June 27, 2013 at 01:37 AM

    So I have an Authorize.net gateway setup. I found a little bug. Basically I have the payment wizard setup so that there are two products and they can only purchase one instead of multiple. The first is a simple product with one price, the second is a prodcut that has special custom pricing. The reason I mention this is because I have a condition setup so that if the user chooses the second product then it hides a field. Now this works perfectly if I actually click on the radio button of the second product. If I choose one of the special pricing drop down the second product gets automatically chosen and my condition does not work. Hence it does not hide the field. I am wondering if I need to setup the conditions differently or if this is a bug I can't get around. Perhaps it has to do with the fact that I have one condition for my products which hides the field and then another radio button down below which shows the field again. I realize this is all a little confusing but I am pretty sure its a bug.

  • Profile Image
    EltonCris
    Answered on June 27, 2013 at 03:35 AM

    Hi,

    I was able to replicate the problem. This might be due to the fact that conditions only triggers when the product it self is clicked not it's quantity. I understand that the product is automatically checked once it's assocaited quantity changes it's value so I will forward this to our higher team. This might be a slight glitch on the conditions or on the product system. 

    We will let you know here once there's any progress on this ticket. Thanks!

  • Profile Image
    usara
    Answered on June 27, 2013 at 11:45 AM

    Thank you so much. By the way. Thank you thank you thank you and your team for the coupon code. That was the only thing holding us up from using JotForm for our registration system. It works like a charm.