Appointment field: Doesn't display available dates and timeslots on Internet Explorer

  • Profile Image
    Arnpriorlibrary
    Asked on June 01, 2020 at 12:12 PM

    About 10% of our patrons are finding the appointment element is "non-clickable" when completing the form

    https://form.jotform.com/201454026168046

    Various browsers:  Chrome, Edge, ie

  • Profile Image
    denis_calin
    Answered on June 01, 2020 at 04:37 PM

    Hi @Arnpriorlibrary!

    Thank you for letting us know. I was not able to replicate the issue on neither Chrome nor Safari nor Firefox. However, I am guessing the following is causing the issue: when you load the form, the Appointment field will load today's date and all of the appointments available for that day. When there are none available, the Appointment field will load the next day with available appointments. It appears that some of your patrons are being shown the Monday's selection page (none appointments available) and are not getting redirected to Tuesday.

    Can you let us know if those patrons are accessing the form on their mobile devices?

    Can you let us know when you first started experiencing this issue? Also, please let us know if the form is embedded on a webpage. If it is, please try embedding the form using the iframe code method, as it is the least conflict-prone method for embedding forms: Getting-the-Form-iFrame-Code.

    Additionally, I have cleared your form caches. Let us know if the issue continues and we will escalate it to our developer team for a fix. Thank you!

  • Profile Image
    Arnpriorlibrary
    Answered on June 01, 2020 at 04:53 PM

    I am uncertain if patrons are using mobile devices.

    The issue first started last week.  We've had a total of 5 patrons call to say they cannot click on the calendar to select a date.  The problem seems consistent on Explorer - I just replicated it from that browser. Clearing the cache has not helped.

    See previous screen shot

    The form is not embedded.  It is linked from an email notification.

    It displays correctly for me on Firefox, Chrome, Opera and Safari.

    One of our patrons who was having issues was using Chrome.  I am uncertain which browsers the others were using.

  • Profile Image
    JohnRex
    Answered on June 01, 2020 at 09:51 PM

    I was able to replicate the issue with Internet Explorer but not with Chrome, Edge, and Firefox.

    15910626012360173.png

    Let me escalate this to our backend team for further investigation. We'll keep you posted here for updates.

    Meantime, you can advise your users to try using Chrome/Firefox as I can see that it's working already on these browsers.

    Apologies for this inconvenience.