Having issues with donations on my jotform

  • Profile Image
    ChairNerd
    Asked on June 02, 2020 at 05:55 PM

    Hi.

    My jotform: https://form.jotform.com/93378905999179 is having trouble with the donations. Please assist. I've had a couple of $10/$20 donations come through but more than 5 people have stated they have had issues with it

    Cell # 828-785-9425

    Thank you,

    Brandy

  • Profile Image
    roneet
    Answered on June 02, 2020 at 09:56 PM

    Is your form embedded on any website?

    May we know what error do you get when you try to make a payment? Please share a screenshot of the error that the user is getting. The payment integration is correctly connected to the form.

    Also, I see the donation field is not a mandatory one so the user can skip filling it. You can mark it mandatory.

    Looking forward to your response.

    Thanks.

  • Profile Image
    ChairNerd
    Answered on June 03, 2020 at 10:58 AM

    Hi thanks for getting back to me. 


    My form is embedded on my website. Should it not be? 
     
    We don't want to make the payment mandatory. 
  • Profile Image
    roneet
    Answered on June 03, 2020 at 12:21 PM

    May we know how have you embedded the form on the website? We recommend using the iFrame embed option. Please re-embed the form using this code if not done already

    Guide: https://www.jotform.com/help/148-Getting-the-Form-iFrame-Code

    May we know the website URL so that we can investigate further.

    Let us know how it goes.

    Thanks


  • Profile Image
    ChairNerd
    Answered on June 09, 2020 at 11:18 AM

    Hi,

    Thanks fore getting back to me. Here is the url: https://silverriverchairs.com/2020-chair-weaving-census/

    We just have the link, we don't really have the form imbedded. 

    Enough people were saying they had trouble, many are older, but one was very much not, so I'm not sure...we were getting some payments, but a handful of people said they were having issues. 

    Cheers,

    Brandy

  • Profile Image
    roneet
    Answered on June 09, 2020 at 12:45 PM

    The form is correctly configured with the Square account.

    I am not sure what error is the user's getting. Could you please ask them what type of trouble were they experiencing?

    In order to troubleshoot we need steps to replicate the issue so that we would be able to provide a solution to you or report to our higher-ups.

    Please provide a screenshot of the error if they were getting any.

    Guide: https://www.jotform.com/help/438-How-to-Post-Screenshots-to-Our-Support-Forum

    What browser were they using to fill up the form?

    Looking for further information.

    Thanks.