when i click on My Forms nothing happens

  • Profile Image
    lalonsi
    Asked on July 02, 2013 at 09:29 PM

    i've been having this issue with your site for a while on Chrome.  i've deleted my cookies, etc and still when i click on 'my forms' 90% of the time nothing happens, hour glass only keeps spinning.  what's going on?  i can't see my submissions.

  • Profile Image
    khrisell
    Answered on July 02, 2013 at 09:37 PM

    This happens when you are not logged in on your account. Are you logged in? Also, if you checked your browser cache, this might be a connection problem with your network.

    Kindly check those and if problem persists kindly let us know so that we could further investigate.

    Thank you.

  • Profile Image
    lalonsi
    Answered on July 02, 2013 at 09:49 PM

    i am logged in... not sure how to check my browser cache however... can you help?

  • Profile Image
    khrisell
    Answered on July 02, 2013 at 10:00 PM

    Yes definitely. The keyboard shortcut to delete cache in Google Chrome is CTRL+Shift+Del and check the “empty the cache” and hit “Clear Browsing Data” button. This is for windows.

    For mac:

    To clear cache in Google Chrome on Mac use Command+Shift+Delete, check the the “empty the cache” and click “Clear Browsing Data” button.

    This keyboard shortcut will also allow you to delete the following information:

    Clear browsing history Clear download history Empty the cache Delete cookies and other site and plug-in data Clear saved passwords Clear saved Autofill form data Clear data from hosted apps Deauthorize content licenses

    After logging out and clearing your caches try to go to your account and try to click "My Forms".

    Let me know if you need further assistance.

  • Profile Image
    lalonsi
    Answered on July 02, 2013 at 10:32 PM

    cleared cache and still no luck... pricing page, support page loads no problem but the My Forms page keeps loading.  sometimes i will get the border but the body of the page (which are my forms) won't display and loading is stopped.

  • Profile Image
    khrisell
    Answered on July 02, 2013 at 10:59 PM

    I went on your Account and was able to load your "My Forms" without any problem.

    May I suggest that you use other browser and check if this will load or not.

    Are you using the latest update of your current browser?

    Thank you for your cooperation. I am sorry we need to undergo this troubleshooting to be able to target what is causing the issue.

    Thank you so much!