Phone number format - extra hyphen?

  • Profile Image
    G3Tech
    Asked on April 28, 2011 at 05:22 PM

    When I enter a phone number field on my form it has two boxes - area code and number.  If I enter the area code with no punctuation and the phone number with a hyphen as in 555   123-4567 it goes into my data as (555)-123-456.  Seems to have an extra hyphen after the area code?  Isn't normal formatting for a phone number (555) 123-4567 or 555-123-4567?  (maybe just USA?)

    Thanks,
    Gregg

  • Profile Image
    NeilVicente
    Answered on April 28, 2011 at 06:44 PM

    Hi,

    While I do believe that this issue seems trivial, you raise a valid point. As such, I have forwarded this to our user request list so that our developers can take a look and see if this change is worth implementing. We'll let you know how this goes.

    Your inputs are highly appreciated. Thank you for using Jotform.


    Neil

  • Profile Image
    Labs
    Answered on May 08, 2011 at 01:31 AM

    Other form building sites do not have this issues...please fix!!!

    Thanks!

    Jimi

  • Profile Image
    G3Tech
    Answered on May 08, 2011 at 01:53 AM

    I'd say some thought could be put into how it should be stored.  For the most flexibility it could be stored just as a string of digits and then be able to apply multiple formats to it in a report or be able to export it to excel where you could format it as you please.  But that complicates things behind the scenes for each report. Would also be nice to have the area code in a separate field since you're prompting for it separately.  That way you can do things by area code (sort, filter etc.).

    For the moment I'd just like to see it look pretty.  One of my clients already told me "You have an extra dash in the phone number.  Would you take care of that?" It makes me look a bit silly.  Also if you were trying to feed this into another program you'd have to write code to clean it up first. 

    Another problem is that now that people have used this in their database and found ways around it, if you fix it they end up wiith mixed format data. Messy.

    So it's really not a trivial problem or solution. 

  • Profile Image
    NeilVicente
    Answered on May 08, 2011 at 03:43 PM

    Hi,

    Like I said I have forwarded this issue to our development team. It is now up to them to decide if they need to change whatever it is that needs changing. I cannot give a lead time though as to when this will be completed.

    Anyway, we appreciate your suggestions and inputs. We would like to thank you for bringing up inconsistencies within the Form Builder. User input such as this definitely contributes to the improvement of Jotform. We will notify you via this thread of any updates regarding this issue.


    Neil

  • Profile Image
    serkan
    Answered on May 14, 2011 at 08:10 AM

    It's fixed now.

  • Profile Image
    Labs
    Answered on May 14, 2011 at 07:37 PM

    Thanks!

    Jimi