Jotform field types is not available for selection with Salesforce in Power Automate app.

  • Profile Image
    S_Lorusso
    Asked on June 09, 2020 at 04:12 PM

    I am using Power Automate to import data from Jotform to SalesForce.

    I am in Power Automate in the Salesforce When I select some of the field types in Salesforce, there are no options for Jotform selector.

    The field types are:

    - Email

    - Single Check Boxes

    - numbers

    Is there a work around for this?


    1591733493Qty.png


  • Profile Image
    Jed_C
    Answered on June 09, 2020 at 09:42 PM

    I just tried it with our Power Automate account and I was able to see the following fields in my salesforce integration.

    - Email

    - Single Check Boxes

    - numbers

    1591753238Create your flow _ Power Autom

    1591753433The Easiest Online Form Builde

    May I know what action are you trying to create for Salesforce? Also, before integration, Salesforce has an option which version of API you will use. May I know which version did you select?

  • Profile Image
    S_Lorusso
    Answered on June 10, 2020 at 10:50 AM

    Your help image shows "Get Records", while I am using "Create Record"

    Your helps image shows you selected on "Filter Query", while my issue is with numbers, hence why the original image i provided you is selected on "Qty of switches installed" which is a number item in Salesforce.

    "Filter Query" is not an email, checkbox, or number item, hence why you see those Jotform Options.

    In fact, none of the items you show in "Get Records" are email, number or checkbox items.

    I have resubmitted your image.


    1591799749Get records.png

  • Profile Image
    Carlos_C
    Answered on June 10, 2020 at 01:51 PM

    Hello,

    Thank you for your message.

    What is the type of fields that are you using for the "Create Record"? Could you please try to create a custom field on salesforce as text and under the Jotform please add a text field for a name instead of a "name" field.

    Please let us know if the text field is mapping using just a text field.

  • Profile Image
    S_Lorusso
    Answered on June 10, 2020 at 03:03 PM

    1) For the number issue, we have come up with a work around.

    Settings were as follows:

         Jotform - text element

         Salesforce - number element

    I changed Jotform to a number element, problem did NOT resolve. (num to num)

    I changed Salesforce to a text field, problem solved. (text to text)


    2) For the email issue, I was looking at it incorrectly. Problem solved


    3) For the check box issue, we have had to come up with a work around. We are changing the fields in Salesforce to be text fields, instead of checkbox fields. Data then comes into Salesforce as text. We will then add some code to Salesforce to hide the text fields and to update the appropriate check box. Problem solved. This is painful though.


    4) New issue -- we are using the "Single Choice" widget in many places in our form. All settings seem to be setup correctly within Power Automate. Although no data is carrying over to Salesforce.

    see 3 images

    1591815464Power Automate.png

    1591815482Salesforce.png

    1591815616Jotform.png

  • Profile Image
    Carlos_C
    Answered on June 10, 2020 at 05:14 PM

    Hi,

    I create a test form with a single choice option https://form.jotform.com/201616677379062 it is integrated directly with salesforce (https://www.jotform.com/integrations/salesforce) and this is the result:

    The single choice field is a Text Area(255):

    Please confirm if the fields on salesforce are text type, if yes must be something that is changing the format in Power Automate.

     

  • Profile Image
    S_Lorusso
    Answered on June 10, 2020 at 08:16 PM

    I figured out the problem. the choices needed to be re-entered. there was a glitch with they way they were entered.

    Problem solved!