Why is there a significant delay between sending and receiving of a form's contents via email?

  • Profile Image
    tecsys
    Asked on April 29, 2011 at 03:35 PM

    I have several Jotforms on my web site. Two of them are for viewers to enter their name and phone number and we will phone them right away. I've set up the forms to send the contents via email to someone in our company. Unfortunately, we are looking bad because I've discovered there is between a 12 to 24 hour delay between the time a viewer submits the form and the time someone at our company receives the email. This is unacceptable. Can someone please explain what could be happening?

    The names of the two forms are: "Have TECSYS Call Me" and "TECSYS vous rapellera". My user name is "tecsys".

    Thank you,

    Paul Harman

    Web Manager, TECSYS Inc.

    www.tecsys.com

  • Profile Image
    abajan
    Answered on April 30, 2011 at 07:10 AM

    Hello tecsys

    Here is the email log of a test message I sent via one of your forms:

    Apr 30 06:31:47 ying sm-mta[13660]: p3UAVj9s013658: to=, ctladdr= (1001/1002), delay=00:00:02, xdelay=00:00:02, mailer=esmtp, pri=120855, relay=tecsys.com.s9a1.psmtp.com. [74.125.148.10], dsn=2.0.0, stat=Sent (Thanks)

     

    Here is the log for the other form:

    Apr 30 06:37:48 ying sm-mta[15601]: p3UAbkh9015599: to=, ctladdr= (1001/1002), delay=00:00:02, xdelay=00:00:02, mailer=esmtp, pri=120829, relay=tecsys.com.s9a1.psmtp.com. [74.125.148.10], dsn=2.0.0, stat=Sent (Thanks)

     

    In a nutshell, both messages were sent okay. Are emails sent from other entities also delayed or are you only experiencing this problem with JotForm? Try setting the sender for both forms to "noreply@jotform" (as shown below) and see if that helps. Also, is there anyway to whitelist messages from the JotForm.com domain?

     

    Please let us know if the suggestions helped to resolve the problem.

    Thanks.