Issue with Conditional Statement appears to be causing form issue

  • Profile Image
    roshawlhh
    Asked on June 30, 2020 at 12:28 PM

    Dear Jotform,

    I have a form that I am having an issue with a conditional statement and when I looked at the condition editor, it looks like the list of fields in the two parts of the statement is a different number and field list.

    I have a statement that asks does a Company use a DBA name.  you can see it is item number 6 on the drop-down list.

    But when I go to select the outcome of the condition to show the next field to enter the DBA name, the list is different and the field to show is now listed as number 6., which was the field number of the previous question, above.  That question is now listed as number 5.

    Note that Language was item number 1 in the condition pull down and the resulting pulldown doesn't list language.  I don't have a question about language unless I accidentally inserted it, but nothing is showing.  But even then, it doesn't show up on both lists.  Seems like I am using two different list tables.  The condition seems to still work in this example, but I have other condition questions when it shows the same out of sync lists and numbers and the condition doesn't seem to work and it shows the next question regardless of the response.

    I was wondering if there is something I need to do to resync the tables.

    Thank you.

    Robert Shaw

  • Profile Image
    VincentJay
    Answered on June 30, 2020 at 02:01 PM

    Do you want to remove the 1 Language in the condition drop-down menu? Or do you want to know that is that form field?

    The 1 Language is the reason why Company DBA name is not the same as the bottom dropdown in terms of numbering. Is that the issue you're trying to explain?

    1593539753mhjfky.gif

    We'll wait for your response. Thank you.