Save and Continue later: Changing the page number in the Save and continue later link allowing users to submit the form without filling the required

  • Profile Image
    techdesk
    Asked on July 06, 2020 at 06:45 AM
    We have thought that all the blanks are mandatory to fill out and when all the blanks are filled out, the parent can move to the next page. 

    The document has not had any information. 

  • Profile Image
    Bojan_J
    Answered on July 06, 2020 at 06:54 AM

    Only fields set as required ones are mandatory to be filled out. If the user tries to go to the next page without filling all the fields, they will get an error message, and the empty required fields will be highlighted in red. 

    Required fields are marked with a red asterisk next to the field. To make a field required one, you can right-click it, and select require. 

    Please let us know if this answers your question. 

  • Profile Image
    techdesk
    Answered on July 07, 2020 at 01:11 AM

    We talked and asked the parents yesterday if they tried to skipped the fields. 

    Their answer is NO. They tried to filled out all the blanks and attached files which they are supposed to do. 


    But we could not find any files or any answers from blanks. 

  • Profile Image
    Kiran
    Answered on July 07, 2020 at 03:58 AM

    Could you provide us with the ID of the submission that you have received without the data on a required fields?

    You may find the submission ID by following the guide below:

    https://www.jotform.com/help/549-Where-to-Find-the-Submission-ID

    Are there any other submissions with the similar issue? Also, please check if the user has tried saving the submission and submitted it later.

    We will wait for your response. Thank you! 


  • Profile Image
    Fairport
    Answered on July 07, 2020 at 02:49 PM

    I have the exact same issue. I have a required field that gave me a blank result. Either the user was able to bypass the question (which I don't understand how this is possible) or perhaps they did enter a response but it came up blank in the submission. 

    I can't seem to replicate this error. When I test my form, the submission comes back complete with all the required fields being captured. I even ran a test where I hit Save for Later and the submission came out correct with all the responses filled out correctly. 

    The required field is a File upload field. I even tested it with a VERY large file to see whether that was the issue, but no, the large file uploaded correctly. 

  • Profile Image
    Welvin
    Answered on July 07, 2020 at 06:56 PM

    @Fairport,

    Allow me to address your problem through a separate ticket below.

    https://www.jotform.com/answers/2435299

    I'll be on it shortly. 

  • Profile Image
    techdesk
    Answered on July 07, 2020 at 09:00 PM
    ID 4695721539011021178Submission Date 2020-07-03 16:55:54

    I hope this might help your understanding, checking and solving out this issue. 


  • Profile Image
    Kiran
    Answered on July 07, 2020 at 11:46 PM

    Thank you for providing with the submission ID. As I check the submission, it is filled with only the last page fields with the Terms acceptance, Signature and date fields. I am able to replicate the issue at my end on your form. The issue seems to be with the Save and continue later link where the user was able to change the page number and submit the form without filling the fields in the previous pages.

    I am sending the ticket to our backend team for further investigation. If we have any news in this regard, we'll let you know here.

    Thanks!

  • Profile Image
    techdesk
    Answered on July 08, 2020 at 02:21 AM

    @Welvin @Kiran and @Bojan_J

    Today I have another parent who tried to fill out. 

    But we have some problem just happened. 

    Actually it is getting worse. 

     ID 4695721539011021178Submission Date 2020-07-03 16:55:54 shows me the name of the parent

    However

    The latest one


    ID 4699888782619566905 Submission Date 2020-07-08 12:41:19 gives me nothing.  There is no name, no information, anything!

    Please help me as soon as possible 

  • Profile Image
    Bojan_J
    Answered on July 08, 2020 at 06:08 AM

    Thank you for the additional information.

    My colleague has already forwarded this problem to our Developers, and as soon as we hear back from them, we will let you know.

    Thank you for your patience. 

  • Profile Image
    Kiran
    Answered on July 08, 2020 at 07:24 AM

    @techdesk,

    Sorry for the confusion. The new submission was sent by me to replicate the issue. I thought I was testing on the cloned form but it was the original form. Usually, the users should be able to access the saved form from the link received to their emails and continue normally. The issue should be occurring only when one tries to change the page number manually and submit the form. Otherwise, it should be working fine.

    Since we have sent the issue for our backend team investigation, let's wait for an update from them. We'll let you know as soon as have any news in this regard.

    Thanks!