HIPAA Square integration: Not getting the option to charge the preauthorized credit card

  • Profile Image
    UrgentCare4U
    Asked on July 07, 2020 at 03:11 AM

    My form submissions do not have a link to charge the preauthorized credit card. Since this is a HIPAA compliant form, it does not show on the emails either. How can I charge?

  • Profile Image
    Sonnyfer
    Answered on July 07, 2020 at 04:49 AM

    Hi - Apologies for the inconvenience.

    As we have very limited access to HIPAA-enabled accounts, could you please send us a screenshot of what it looks like when you try to charge from your submissions page?

    Guide: How-to-Post-Screenshots-to-Our-Support-Forum 

    Meantime, could you please try turning off PHI on the payment field to check if it makes any difference?

    1594111777offx.png

    Looking forward to your reply.

  • Profile Image
    UrgentCare4U
    Answered on July 07, 2020 at 09:38 AM

    159412905872A5B5B5-E7A6-4FFD-A499-86D8A4

  • Profile Image
    Sam_G
    Answered on July 07, 2020 at 10:25 AM

    Hi UrgentCare4U,

    Thank you for the information.

    Could you let us know if you were able to charge the other users for the earlier submission on the same form?

    Also, please check the Square transaction history if the transaction has already been charged.

    We also request you to check with Square support by providing them with the transaction ID that might help. 

    Please get back to us if you need any further assistance. We will be happy to help.

  • Profile Image
    UrgentCare4U
    Answered on July 07, 2020 at 10:47 AM

    I was able to charge on the email before the HIPAA features were activated I have disabled the PHI toggle om the credit card section for future transactions. These have not been charged

  • Profile Image
    Sam_G
    Answered on July 07, 2020 at 01:00 PM

    Hi UrgentCare4U,

    Let me work on this and will update you via this ticket.

  • Profile Image
    Sam_G
    Answered on July 07, 2020 at 01:22 PM

    Hi UrgentCare4U,

    I have cloned your form and tested it on our HIPAA  test account.

    The link is working on the regular form but on the HIPAA test account, Square integration is getting an error.

    I have escalated the issue to our back-end team for further investigation.


    They will contact you via this thread once updates are available.