My required fields are not working.