Custom background using css not displaying correctly

  • Profile Image
    perrymanku
    Asked on July 17, 2013 at 04:57 PM

    Hi I have created this form with a custom background but it does not display the full form

     

    http://form.jotform.co/form/31914460194857

     

    Help would be appreciated

     

    Perry

  • Profile Image
    Mike_T
    Answered on July 17, 2013 at 05:22 PM

    Thank you for contacting us.

    It depends on the height of the .form-all div, so you can add some fields to the form, and this will show the background for these fields.

    Alternatively, try to specify the height for the form div. Here is the code with specified height and added no-repeat property:

    .form-all {
    background:
    url("http://i1102.photobucket.com/albums/g441/perrymanku/Landing-Pagefinal1_zps7cb66455.jpg") no-repeat;
    height: 612px;
    }

    If you need any further assistance, please let us know.

  • Profile Image
    perrymanku
    Answered on July 17, 2013 at 05:26 PM

  • Profile Image
    EliezerN
    Answered on July 17, 2013 at 05:42 PM

    For some reason, we are not able to see your question or comment.

    We would appreciate if you resend it again and in that way, we can assist you if you need it.

    Thanks

  • Profile Image
    perrymanku
    Answered on July 17, 2013 at 05:48 PM

    Hello, I have now got the background to work

     

    http://form.jotform.co/form/31914460194857

     

    How do I now add firelds to it and how do i position them where i want

     

    Thanks

    PErry

  • Profile Image
    EliezerN
    Answered on July 17, 2013 at 06:13 PM

    Since your question is bit different from the original one I will kindly ask you to please open a new thread to make your question and we will be more than glad to assist you.

    Thanks.

  • Profile Image
    mindandbodycodingsystems
    Answered on August 15, 2014 at 01:30 AM

    My background image although showing in the new template and correctly is not displaying at tall in preview mode or when going to the form link. Just a plain white background. 

  • Profile Image
    ashwin_d
    Answered on August 15, 2014 at 05:10 AM

    Hello mindandbodycodingsystems,

    Please take a look at the following cloned form and see if that works as expected:  http://form.jotformpro.com/form/42261841182955? 

    Feel free to clone this form for a closer look. The following guide should help in form cloning:  http://www.jotform.com/help/42-How-to-Clone-an-Existing-Form-from-a-URL 

    Hope this helps.

    Do get back to us if you need any other changes.

    Thank you!

  • Profile Image
    mindandbodycodingsystems
    Answered on August 17, 2014 at 03:23 PM

    I haven't got time for this nonsense. For goodness sake. I should be able to use my existing form after following the instructions for using CSS. I followed those instructions you gave though why I should have to clone a form from a web link of it that some how was showing correctly when my form in edit mode wouldn't or display properly in preview mode. And the problem still exists. From the cloned form I wasn't able to do any edits or save. So that form has now gone.

    I decided to re do the background image and start afresh from bigger template and we're back to the original problem. And haven't the time to spend all day messing around in an attempt to create a contact form when your site or whatever isn't working. I need this form up and running for my business so will now have to find another form site less buggy. 

  • Profile Image
    mindandbodycodingsystems
    Answered on August 18, 2014 at 08:45 AM

    I took a look at that form's CSS coding after cloning it from the web link you provided. The only change was no repeat. And was unable to add any other formatting. I have since started afresh with a new image and now have a contact form the way I like it. 

    Problem. Again the background image won't display in preview mode

    http://form.jotformeu.com/form/42285721160348? 

    If you do manage to fix this issue please do not reduce the size of the form or image. 

    Thank you. 

    p.s 

    This is the last time I am doing this given that other people on your site are having a similar issue with their background images not displaying after following the CSS background image example. 

  • Profile Image
    ashwin_d
    Answered on August 18, 2014 at 10:38 AM

    Hello mindandbodycodingsystems,

    Please take a look at your form where I have resolved the issue of back ground image. Please check the screenshot below:

    Do check and get back to us if you need any other changes.

    Thank you!