I have 2 lightbox forms on one page

  • Profile Image
    troopmedia
    Asked on July 20, 2013 at 01:28 PM

    Hello,

    I have built a job listing app in business catalyst, so for every job that is added to the database it lists them on the page...

    On the bottom of each listing, I'm using a JotForm (ligthbox) that says "Apply for this Job".

    When I have 1 job in the database the lightbox works correctly, when I add the 2nd job, there is a problem with the lightbox script somewhere...

    It puts an extra graybox on top of the form.... 

    I'm including screenshots of 1 job added to the db and another with 2 jobs added to the db, along with the app code...

    Please help if you can.

    Thank you

    David E

  • Profile Image
    KadeJM
    Answered on July 20, 2013 at 02:46 PM

    Hello David, I think I understand the problem but will need some time to investigate this some more to try to figure out what is happening here.

    So far I see two buttons for two different Applications Links which appear to be the same Application Form being used. It looks like there's obviously a conflict that is happening on the page since at first when I loaded the form there was a doubleloaded form probably both of these appearing but one of them was overriding the other which is why I think the first one shows up blank.

    Also may we have your permission to test the firm to check for the greybox which appears after a second application is submitted to help us figure out what's going on if that's okay with you?

  • Profile Image
    troopmedia
    Answered on July 20, 2013 at 03:42 PM

    Sure... that sounds great Kade.

     

    Thank you

  • Profile Image
    troopmedia
    Answered on July 20, 2013 at 03:53 PM

    Kade, if the page to the forms looks a little messed up, it's because I'm working on it... Go a head and do your thing... it will not interfere with what I'm doing.

    Thanks

  • Profile Image
    KadeJM
    Answered on July 20, 2013 at 05:32 PM

    Okay no problem and thanks, that's fine. Just wanted your permission first. We will get back to you about this as soon as possible.

  • Profile Image
    jonathan
    Answered on July 20, 2013 at 05:39 PM

    Hi,

    From what I can see so far on your website page source code view, it seems you had embedded the same form 2x.

     

    Please try removing the 2nd lightbox code and just use the link for the lightbox for the 2nd job. Check if this help.

    Thanks.