Form builder drag & drop does not work

  • Profile Image
    Asked on July 20, 2013 at 07:43 PM


    Hey guys

    I have noticed for MONTHS now that the ability to drag and drop fields within the editor, does not work.  What I mean is when I want to adjust the position of a question, I have to right click and select my option instead of drag and drop.  This hasnt worked for me for months.  Now I have a form where I need to move something from the top all the way to the bottom so now I am saying something.  

    I think I asked about it awhile ago and I was told it works and works on your end but it does not work on my end.  Doesn't work in Chrome or FF.  


  • Profile Image
    Answered on July 20, 2013 at 08:35 PM


    Yes, definitely we couldn't replicate the problem. I asked my other colleagues who are from different locations and they don't encounter this problem. Drag and drop works completely fine on my end, IE9, FF, Chrome and Opera. We also do not have similar reports about this, if this is an issue on our side, I'm sure we'd get trending reports about this.

    Anyway, I would recommend to check everything on your end, browser's javascript, try to clear its cache and cookies or if you have another desktop or laptop, try it out there, I'm sure it would work fine. May we also suggest to update your browsers if necessary. Another possible reason is due to your computer graphics which may slow down every browser object movements specially when dragging elements. Kindly check that as well.

    Please take every suggestions and let us know what your findings are.

    Well wait your reply. Regards!

  • Profile Image
    Answered on July 20, 2013 at 08:56 PM

    What do you mean by the computer graphics?  I have GIMP - Image Editing software open...could that contribute to the problem?

    It doesn't work in FF or Chrome so my guess is its a problem with my computer?  How do you update javascript? 

  • Profile Image
    Answered on July 20, 2013 at 09:19 PM


    Thanks for your quick reply.

    Sorry, I am referring to your graphic card drivers, if you don't experience slowness or something laggy in your computer, you can ignore this.

    Yes, I worked using Chrome and I have different browsers installed. You can check my screencast taken just now.

    I couldn't say exactly if that's an issue with your PC, but if you have any other computer to test or laptop, maybe you can find it out there. There's no need to update javascript, just kindly check if it's enabled. I would also suggest to clear your browser's cache and cookies.


  • Profile Image
    Answered on April 16, 2014 at 10:31 AM

    Good morning. I, too, have had the same problem for ~6months. I ran through making sure that javascript was enabled, as you suggested above, and regularly clear my browser cache & cookies. Still nothing. When I attempt to drag and drop Chrome tries to highlight the text.

    I'm running the following version of Chrome on a Windows 7 machine:

    Version 34.0.1847.116 m


    Any assistance would be greatly appreciated.

  • Profile Image
    Answered on June 04, 2014 at 10:31 PM

    Same problem here. cant drag and drop in chrome
  • Profile Image
    Answered on April 07, 2015 at 10:29 PM

    Same problem.  Can't drag and drop in Chrome.
  • Profile Image
    Answered on June 04, 2015 at 10:52 AM

    @reciproc8, were you on Windows 8 when you can't drag & drop using Chrome?

  • Profile Image
    Answered on June 10, 2015 at 02:53 PM

    I am having the same issue with chrome, in Windows 8. Any solution out there?

  • Profile Image
    Answered on June 10, 2015 at 03:46 PM

    This should now be sorted.  Try clearing your browsers cache/cookies to ensure the old code is not still loading.  If the drag and drop issues persists beyond that, let us know which version of Chrome you are using and we will be happy to have another look.

  • Profile Image
    Answered on June 16, 2015 at 05:20 AM

    Done clearing caches/JotForm's cookies and the issue still persists.


    My Chrome Version: 43.0.2357.124m

  • Profile Image
    Answered on October 23, 2015 at 08:00 PM

    Same problem. Tried all solutions. Not working still.
  • Profile Image
    Answered on March 08, 2016 at 09:44 AM


    I have moved your question here We'll be on this thread shortly.